NECKO: M7 Crashes when given localhost url

VERIFIED FIXED in M9

Status

()

Core
Layout
P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Deleted User, Assigned: Gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Hi, I just tried entering the following url into M7:
'http://localhost/cyberstorm/builder.php?url=index'. This url doesn't exist
here, but I tried it anyway and the entire window containing it froze, wouldn't
respond to window redraws nor the X icon in WindowMaker-0.60.0. Had to CTRL-C
from my e-term running ./mozilla-apprunner.sh to close and restart it. The
message presented was as follows:
FindShortcut: in='http://localhost/cyberstorm/builder.php3?url=index'
out='null'
Loading  url http://localhost/cyberstorm/builder.php3?url=index in WEbshell
83c1cf0

Now, I tried it again, and it stayed up, with the following error:
FindShortcut: in='http://localshost/cyberstorm/builder.php?url=index'
out='null'
Loading  url http://localshost/cyberstorm/builder.php?url=index in WEbshell
83e0468
nsDocumentBindInfo::OnStopBinding: Load of URL
'http://localshost/cyberstorm/builder.php?url=index' failed.  Error code: 1
Error loading URL http://localshost/cyberstorm/builder.php?url=index
Document: Done (2.686 secs)
Got a handle to forward menu item
Setting forward menu item disabled
Obtained MenuItem Back
Setting Back menuitem to enabled
Alert: Alert! did not find a converter or
decodernsDocumentBindInfo::OnStopBinding: Load of URL
'file:////usr/src/mozilla/M7/package/res/throbber/anim.gif' failed.  Error code:
1

Which is fine, but that last one was done from a fresh run of M7, not having had
a page loaded before in that session.

Running RedHat 6.0, Netscape-4.6 alongside M7 binary, apache-1.3.6, php-3.0.9.
Cannot repeat it :(

Updated

19 years ago
Assignee: don → rickg
Component: Browser-General → Layout
QA Contact: leger → petersen

Comment 1

19 years ago
petersen..you see this?

Comment 2

19 years ago
Jan- I'm having a problem installing the latest build on the Linux. I tried to
reproduce this issue on Mac and Windows but can't reproduce (JUN 28TH
1999062808).

Comment 3

19 years ago
Jan- I'm having a problem installing the latest build on the Linux. I tried to

reproduce this issue on Mac and Windows but can't reproduce (JUN 28TH

1999062808).

Updated

19 years ago
Assignee: rickg → dp

Comment 4

19 years ago
DP -- this really looks like a URL handling problem in apprunner. Can you take a
look please?

Updated

19 years ago
Assignee: dp → warren

Updated

19 years ago
Assignee: warren → gagan

Comment 5

19 years ago
Gagan can you make sure this works in necko? Thanks.
(Assignee)

Comment 6

19 years ago
Past necko landing...
(Assignee)

Comment 7

19 years ago
Should work in Necko. Pl. verify.
(Assignee)

Updated

19 years ago
Summary: M7 Crashes when given localhost url → NECKO: M7 Crashes when given localhost url

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
I'm not seeing this problem in the Aug 16th build.
You need to log in before you can comment on or make changes to this bug.