Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 890034
5 years ago
5 years ago

People

(Reporter: hub, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
This is a regression.

Session restore fails: I have an empty list in the session restore dialog.

This happens on mozilla-inbound
revision 137098:83a2966d94fb

First good revision is 
136836:3029d3574f2e

(currently bisecting)

This is on Linux
You'll need to be a little more specific, please. What did you do? Just (re)start your browser as usual?
(Reporter)

Comment 2

5 years ago
Yep, just restart my browser as usual. I may have quit it by "control-C" in the terminal before so I expect to get the session restore after crash dialog. I got it empty. If I revert back to 136836:3029d3574f2e it works as expected. (this is m-i)
(Reporter)

Comment 3

5 years ago
Here is the result of hg bisect:

The first bad revision is:
changeset:   136962:2858a7580535
parent:      136953:21fbbc433934
parent:      136961:eb6cf1052d77
user:        Phil Ringnalda <philringnalda@gmail.com>
date:        Sun Jun 30 08:35:45 2013 -0700
summary:     Merge fx-team to m-c

Not all ancestors of this changeset have been checked.
Use bisect --extend to continue the bisection from
the common ancestor, e1751478d411.

I guess I have to continue to nail it down
(Reporter)

Comment 4

5 years ago
The first bad revision is:
changeset:   136959:cdf1be4ca282
parent:      136807:e1751478d411
parent:      136958:58bc53e378a1
user:        Ed Morley <emorley@mozilla.com>
date:        Fri Jun 28 14:37:15 2013 +0100
summary:     Merge mozilla-central and fx-team

Not all ancestors of this changeset have been checked.
Use bisect --extend to continue the bisection from
the common ancestor, 52f605debfd4.

Continuing further.
(Reporter)

Comment 5

5 years ago
According to hg bisect, this is the revision causing the regression:

The first bad revision is:
changeset:   136954:086465524970
parent:      136710:52f605debfd4
user:        Tim Taubert <ttaubert@mozilla.com>
date:        Thu Jun 27 10:32:04 2013 -0400
summary:     Bug 887394 - Don't collect state right after startup when restoring the initial session; r=yoric
(Reporter)

Comment 6

5 years ago
Step to reproduce.

Linux.

-Quit your browser doing control-C
-hg update to m-i revision 137098:83a2966d94fb (or the equivalent changeset on m-c)
-rebuild firefox
-restart firefox (from the command line)

Expected

-the restore session should list all my open tabs

Observed

-I have an empty list of tabs to restore.

This is a regression, see comment #5 for the culprit.
Duplicate of this bug: 890624
Blocks: 887394
Keywords: regression
Just my opinion, but I think we need to back-out the patch for bug 887394 and improve test coverage for Session restore for all the regressions caused by this check-in for which we seem to have inadequate test coverage.  Then, perhaps, try again.
Duplicate of this bug: 890749

Comment 10

5 years ago
hubert, was your sessionstore.js set to 0 bytes
(Reporter)

Comment 11

5 years ago
No. It was 4430738 bytes.
I'm assuming this is accompanied by an error saying "treeView.treeBox is null on about:sessionrestore". Duping to bug 890034. Please reopen if you don't see this error.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890034
Duplicate of this bug: 892043
(Reporter)

Comment 14

5 years ago
(In reply to Tim Taubert [:ttaubert] from comment #12)
> I'm assuming this is accompanied by an error saying "treeView.treeBox is
> null on about:sessionrestore". Duping to bug 890034. Please reopen if you
> don't see this error.
> 
> *** This bug has been marked as a duplicate of bug 890034 ***

I don't know where the error appears, but it doesn't show up in the terminal (I start Firefox from the command line). This AM m-i still had it but I don't see any indication it should be otherwise.
Sorry, I don't actually see an error myself but would rather blame this on the broken error reporting. I'm quite sure it will be fixed by bug 891360 as well.
(Reporter)

Comment 16

5 years ago
Indeed it has been fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.