All users were logged out of Bugzilla on October 13th, 2018

Firefox does not reload fonts

RESOLVED DUPLICATE of bug 862222

Status

()

RESOLVED DUPLICATE of bug 862222
5 years ago
5 years ago

People

(Reporter: johan.mattsson.m, Unassigned)

Tracking

22 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

886 bytes, application/octet-stream
Details
1.11 KB, application/octet-stream
Details
755 bytes, text/html
Details
(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130620122336

Steps to reproduce:

1. Create a font and a webpage, link the font in the CSS file (or use the preview functionality in http://birdfont.org/)
2. Open the html file
3. Edit the font
4. Press reload


Actual results:

The font is not updated with the rest of the document.


Expected results:

The entire page should be updated, including the font.

Comment 1

5 years ago
Provide a testcase, please.
Flags: needinfo?(johan.mattsson.m)
(Reporter)

Comment 2

5 years ago
Created attachment 770176 [details]
Font file
Flags: needinfo?(johan.mattsson.m)
(Reporter)

Comment 3

5 years ago
Created attachment 770178 [details]
Font file
(Reporter)

Comment 4

5 years ago
Created attachment 770180 [details]
Font test
(Reporter)

Comment 5

5 years ago
Here is a way to reproduce the problem:
1. Download the two font files and the html document.
2. Open the html document in Firefox. The letter "a" will be replaced by a triangle if the font is loaded.
3. Edit the font file. (I use BirdFont but FontForge and other editors should work as well). If you don't want to install a font editor can you replace the ttf file with another font.
4. Reload the page.
(Reporter)

Comment 6

5 years ago
Another way to reproduce this problem is to delete the ttf file and reload the page.

Updated

5 years ago
Attachment #770180 - Attachment mime type: text/plain → text/html

Updated

5 years ago
Component: Untriaged → Layout: Text
Product: Firefox → Core

Comment 7

5 years ago
In FF25, if I delete the ttf file then:
- I reload the page (F5): the triangle stays visible
- I force the cache to reload (Ctrl+F5): "a" is back

Could you test with nightly, please.
http://nightly.mozilla.org/
Flags: needinfo?(johan.mattsson.m)
(Reporter)

Comment 8

5 years ago
The bug seems be present in Mozilla Firefox 25.0a1 too. I got the same result as in 22.0.
Flags: needinfo?(johan.mattsson.m)
(Reporter)

Comment 9

5 years ago
I forgot to close 0.22 before I started 0.25a. I get the same result as you do in FF25. The font is reloaded only with Ctrl+F5. Maybe it is a feature.
Yes, it's a feature (implemented in bug 816483). To optimize the normal user experience, webfonts are not re-fetched when a page is reloaded (or when a subsequent page uses the same font resource); when possible, we simply re-use the same font instance that we've already created on the platform.

In bug 862222, we added support for forcing the font to be reloaded (using Ctrl-F5, or holding Shift while clicking the Reload icon, I think). This is mainly intended for authors/developers who may be modifying the actual font resource and want to see the effect of their changes without quitting the browser; normal users shouldn't need to worry about this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862222
(Reporter)

Comment 11

5 years ago
Thank you.
You need to log in before you can comment on or make changes to this bug.