The HTML 5 web app hosted at https://www.cubeslam.com/ does not load

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: sidcool1234, Assigned: Ehsan)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox23 unaffected, firefox24+ disabled, firefox25+ wontfix)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130701 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130701031115

Steps to reproduce:

1.  Access https://www.cubeslam.com/


Actual results:

The screen shows Loading and does nothing further.


Expected results:

The screen should load and go to the game.
(Reporter)

Comment 1

5 years ago
Just FYI, this is an issue in nightly build version 25.0a1 (2013-07-01)
(Reporter)

Updated

5 years ago
Priority: -- → P3
(Reporter)

Updated

5 years ago
(Reporter)

Updated

5 years ago
tracking-firefox25: --- → ?

Comment 2

5 years ago
There is probably a regression but it's hard to bisect due to crashes with this website (see bug 882589). :/
Keywords: regressionwindow-wanted
Priority: P3 → --

Comment 3

5 years ago
I think the regression range is:
good=2013-06-23
bad=2013-06-24
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4c4f75c20e9b&tochange=76820c6dff7b

Indeed, the crash occurs only when Firefox is able to load and display the game, so it shows indirectly a good build. If not, the loading page stays in infinite loop.

Web console:
[16:47:24.891] TypeError: (intermediate value).createGainNode is not a function @ https://www.cubeslam.com/javascript/slam.min.js?v=live.368036945984965839:7
[16:47:25.351] NS_ERROR_UNEXPECTED: Unexpected error @ https://www.cubeslam.com/javascript/slam.min.js?v=live.368036945984965839:4

Comment 4

5 years ago
(In reply to Loic from comment #3)
> I think the regression range is:
> good=2013-06-23
> bad=2013-06-24
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=4c4f75c20e9b&tochange=76820c6dff7b
> 
> Indeed, the crash occurs only when Firefox is able to load and display the
> game, so it shows indirectly a good build. If not, the loading page stays in
> infinite loop.
> 
> Web console:
> [16:47:24.891] TypeError: (intermediate value).createGainNode is not a
> function @
> https://www.cubeslam.com/javascript/slam.min.js?v=live.368036945984965839:7
> [16:47:25.351] NS_ERROR_UNEXPECTED: Unexpected error @
> https://www.cubeslam.com/javascript/slam.min.js?v=live.368036945984965839:4

It crashes(bug 882589), if set media.webaudio.legacy.AudioContext = true.
So, I think this forever loading is caused by landing of Bug 886165.

Comment 5

5 years ago
Confirmed, yes.
Blocks: 886165
Status: UNCONFIRMED → NEW
status-firefox23: --- → unaffected
tracking-firefox24: --- → ?
Component: Untriaged → Web Audio
Ever confirmed: true
Keywords: regressionwindow-wanted → regression
Product: Firefox → Core
Version: 25 Branch → 24 Branch
(Assignee)

Comment 6

5 years ago
I'll try to find somebody inside Google who knows who to talk to about this.
Assignee: nobody → ehsan
Component: Web Audio → English US
Product: Core → Tech Evangelism
Version: 24 Branch → Trunk

Updated

5 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
tracking-firefox24: ? → +
tracking-firefox25: ? → +
(Assignee)

Comment 7

5 years ago
The demo was fixed yesterday to finish loading but there are still problems in it preventing audio playback from working.  The Google folks are working on a fix.
(Assignee)

Updated

5 years ago
Depends on: 891986
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #7)
> The demo was fixed yesterday to finish loading but there are still problems
> in it preventing audio playback from working.  The Google folks are working
> on a fix.

Hey :Ehsan, is there any news about this yet ? Given Fx24 is going to be released soon, can we increase the sense of urgency from our side ?
(Assignee)

Comment 9

5 years ago
(In reply to comment #8)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #7)
> > The demo was fixed yesterday to finish loading but there are still problems
> > in it preventing audio playback from working.  The Google folks are working
> > on a fix.
> 
> Hey :Ehsan, is there any news about this yet ? Given Fx24 is going to be
> released soon, can we increase the sense of urgency from our side ?

Firefox 24 has Web Audio disabled, so should not be affected by this. Am I missing something?
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #9)
> (In reply to comment #8)
> > (In reply to :Ehsan Akhgari (needinfo? me!) from comment #7)
> > > The demo was fixed yesterday to finish loading but there are still problems
> > > in it preventing audio playback from working.  The Google folks are working
> > > on a fix.
> > 
> > Hey :Ehsan, is there any news about this yet ? Given Fx24 is going to be
> > released soon, can we increase the sense of urgency from our side ?
> 
> Firefox 24 has Web Audio disabled, so should not be affected by this. Am I
> missing something?

Ah, my bad, sorry ! Marking the status flags appropriately to avoid confusion.
status-firefox24: affected → disabled
(Assignee)

Comment 11

5 years ago
I just contacted the CubeSlam team again.
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #11)
> I just contacted the CubeSlam team again.

Let me know if there's anything I can do to push this along as well.
(Assignee)

Comment 13

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #12)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #11)
> > I just contacted the CubeSlam team again.
> 
> Let me know if there's anything I can do to push this along as well.

I have not yet heard back... :/

Updated

5 years ago
status-firefox25: affected → wontfix
Issue still exists with audio.

Ehsan: I'm guessing we still haven't heard back?
Component: English US → Desktop
Flags: needinfo?(ehsan)
(Assignee)

Comment 15

4 years ago
No :(
Flags: needinfo?(ehsan)
Cute bear. The site has been fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.