[Notes] Notes in "Trash" ignored while selecting "All Notes"

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: matias)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3rd Party][apps watch list1][TD-55834])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 770111 [details]
All notes section will not display messages in Trash

STR:
  1. Click add note and save a note.
  2. Delete the created note, so it will be moved to "Trash".
  3. Click menu and the note deleted will be present in "Trash".
  4. Click "All Notes".

Expected:
  The note moved to "Trash" should be displayed.

Actual:
  "Your trash is empty" message will be displayed.
Flags: needinfo?(jsmith)
Probably just yet another partner app bug. I'll add this onto our tracker bug and one of the partners who build this take a look at this.
Blocks: 869212
Flags: needinfo?(jsmith)

Updated

5 years ago
Whiteboard: [3rd Party] → [3rd Party][apps white list1]
(Reporter)

Updated

5 years ago
Whiteboard: [3rd Party][apps white list1] → [3rd Party][apps white list1][TD-55834]

Updated

5 years ago
Assignee: nobody → hkirschner
Whiteboard: [3rd Party][apps white list1][TD-55834] → [3rd Party][apps watch list1][TD-55834]

Updated

5 years ago
Assignee: hkirschner → dpreston
I recommend closing this as INVALID, as the behavior is arguably by design.  The Trash folder is not a normal folder, it exists solely as an "oops, I didn't mean to delete that" folder.

Showing "All files" and searching on OS X behaves the same way as reported in the bug.
That sounds reasonable to me.
No longer blocks: 869212
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

5 years ago
Lisa, In that case the string showing "Your trash is Empty" in the screenshot is in conflict because there are notes present in Trash folder.
Flags: needinfo?(adora)
Assignee: dpreston → ran
(Reporter)

Comment 5

5 years ago
ni for your comments.
Flags: needinfo?(jsmith)
Trashed Notes are not in "All notes" by design.

But, the fact that an empty "All notes" displays "Your trash is empty" is a bug and we're on it.
Assignee: ran → matias
(Assignee)

Comment 7

5 years ago
fix submitted to marketplace as version 1.0.2
(Reporter)

Comment 8

5 years ago
I checked the market place for this version. But couldn't find it, and tested on available latest version and could reproduce this.

Jason can you verify this.
Flags: needinfo?(adora)
(Assignee)

Comment 9

5 years ago
Leo, its still Pending approval on the marketplace, thats why you couldn't find it.
Looks like comment 9 has answered your question.
Flags: needinfo?(jsmith)
(Assignee)

Comment 11

5 years ago
version 1.0.2 has been approved on marketplace
(Reporter)

Updated

5 years ago
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.