Advanced Edit: All elements with border, hspace, and vspace attributes should only accept numeric values

VERIFIED FIXED in mozilla0.9.4

Status

()

P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: rubydoo123, Assigned: cmanske)

Tracking

Trunk
mozilla0.9.4
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dialog])

(Reporter)

Description

18 years ago
the IMG element border attribute should only allow numeric values
(Reporter)

Comment 1

18 years ago
bae
Assignee: beppe → cmanske
Keywords: correctness
Priority: -- → P3
Whiteboard: [dialog]
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 2

18 years ago
the vspace and hspace attributes have the same issue
Summary: Advanced Edit: IMG element border attribute should only accept numeric values → Advanced Edit: IMG element border, hspace and vspace attributes should only accept numeric values
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.4
(Assignee)

Comment 3

17 years ago
Changing summary to include all elements that use "vspace" and "hspace".
All should be numeric-only.
Summary: Advanced Edit: IMG element border, hspace and vspace attributes should only accept numeric values → Advanced Edit: All elements with hspace and vspace attributes should only accept numeric values
(Assignee)

Comment 4

17 years ago
*** Bug 89437 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
Fix is to add the '#' signal character to do filtering of input for integers:
For the IMG element:
  "ismap",
  "align",
-  "border",
-  "hspace",
-  "vspace",
+  "#border",
+  "#hspace",
+  "#vspace",
  "-",
  "_core",

and for the APPLET element:

  "align",
-  "hspace",
-  "vspace",
+  "#hspace",
+  "#vspace",
   "-",

and the OBJECT element:
  "name",
  "#tabindex",
  "align",
-  "border",
-  "hspace",
-  "vspace",
+  "#border",
+  "#hspace",
+  "#vspace",
  "-",
Keywords: review
Summary: Advanced Edit: All elements with hspace and vspace attributes should only accept numeric values → Advanced Edit: All elements with border, hspace, and vspace attributes should only accept numeric values
Whiteboard: [dialog] → [dialog]FIX IN HAND need r=, sr=

Comment 6

17 years ago
r=brade
Whiteboard: [dialog]FIX IN HAND need r=, sr= → [dialog]FIX IN HAND need sr=

Comment 7

17 years ago
sr=kin@netscape.com
Whiteboard: [dialog]FIX IN HAND need sr= → [dialog]FIX IN HAND, reviewed
(Assignee)

Comment 8

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: review
Resolution: --- → FIXED
Whiteboard: [dialog]FIX IN HAND, reviewed → [dialog]

Comment 9

17 years ago
Verified on 8-30 Build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.