[B2G][Leo][Cellular & Data] No networks are displayed when searching for networks

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Settings
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Jeni, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: leorun4, retest_leorun4)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
When user searches for networks no networks are displayed

Repro Steps:
1) Updated to Leo Build ID: 20130625070217
2) Tap on Settings
3) Tap on Cellular & Data
4) Scroll to and select Network Operator
5) Turn automatic selection off
6) View what happens

Actual:
No networks are shown

Expected:
Networks in area show.  In area located at now 2 networks will show

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1
RIL Version: 01.01.00.019.138 

Notes:
Repro frequency: 100% 3/3
Test Suite Name: Cellular & Data
UCID: 3537
Link to failed test case: https://moztrap.mozilla.org/runtests/run/1600/env/314/?&pagenumber=1&pagesize=50&sortfield=order&sortdirection=asc&filter-id=3537&filter-suite=158
See attached screen shot and attached log-cat for more information
(Reporter)

Comment 1

5 years ago
Created attachment 770245 [details]
Screenshot of issue
(Reporter)

Comment 2

5 years ago
Created attachment 770246 [details]
Logcat of issue
(Reporter)

Updated

5 years ago
Whiteboard: leorun4

Comment 3

5 years ago
I have seen this also.   Although I'm ultimately able to find and access a network, this can at least create a perception problem (feature appears not to work, even though it actually does.)  Nomming.
blocking-b2g: --- → leo?

Comment 4

5 years ago
Dear Jeni.

The screenshot showed 'searching'.
It means the manual search isn't done yet.

Sometimes manual search takes more than 1 min ~ 2 min. ( It depends on network environment )

But the log captured just 1 min after starting manual search.

07-02 10:01:35.109: I/Gecko(145): -*- QCContentHelper_QC_B2G: receiveMessage: 'RIL:GetAvailableNetworks' arrived from content process // start manual search
...
07-02 10:02:34.999: I/ONCRPC(148): oncrpc_proxy_handle_cmd_rpc_call: Dispatch returned for xid: 564 // The last line of the log.

1. Please wait more than 2 min after starting manual search.
2. Capture the log more than 2 min after starting manual search.
3. capture modem log ( QXDM log ) if it is possible.

Thanks.
Flags: needinfo?(jcouassi)
(Reporter)

Comment 5

5 years ago
Created attachment 772144 [details]
Logcat of 5 + mins searching for network

Searched for network for more then 5 minutes.  unable to find anything in a location.
Flags: needinfo?(jcouassi)

Comment 6

5 years ago
It is not reproduced with Leo version.
Please check with origina leo version.

It seems to be that the RIL interface is different with test version and leo version.

Comment 7

5 years ago
The log attated showed to me it's not leo RIL interface.
Still repros on Leo 1.1 commercial RIL.

Build ID: 20130715070218
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
Gaia: 55ed5e08a2250ea2d3571fff860c39e66fabed14
Platform Version: 18.1
RIL Version: 01.01.00.019.158
Whiteboard: leorun4 → leorun4, retest_leorun4

Comment 9

5 years ago
Please attach the new log in comment 8.
mvines, is there a new RIL we should be picking up? sounds like leo can't repro with their comm_ril, but we can.
Flags: needinfo?(mvines)

Updated

5 years ago
Flags: needinfo?(ckreinbring)
Does this issue reproduce with the unaltered partner image using that particular device/simcard/location?
Flags: needinfo?(mvines)

Comment 12

5 years ago
Issue no longer seems to be occurring on the latest Leo build from the commercial v1.1 branch:

Environmental  Variables:
Build ID: 20130716070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/629020cf576b
Gaia: fb9362d34260771d4a00b9a0e10a6bbad397bd3b
Platform Version: 18.1
RIL Version: 01.01.00.019.158

After disabling automatic network selection and waiting for about 1 minute, the list populates with several options. I'm seeing the following options: AT&T, 31026, and GSM.

Resolving issue as works for me.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Status: RESOLVED → VERIFIED
Triage - although resolved, leo+ing if bug still occurs given the description.
blocking-b2g: leo? → leo+

Comment 14

5 years ago
Using the Leo partner build from June 20th on three devices, we were unable to repro this issue.

We were able to repro the issue on two out of six devices, one of which was on the 07/17 com ril build and the other being on 07/18 com ril build.
Flags: needinfo?(ckreinbring)
You need to log in before you can comment on or make changes to this bug.