Closed Bug 889527 Opened 7 years ago Closed 7 years ago

At debug-build startup: "JavaScript warning: chrome://browser/content/places/controller.js, line 940: yield without a value is deprecated, and illegal in ES6 (use 'yield undefined' instead)"

Categories

(Toolkit :: Places, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 887320

People

(Reporter: dholbert, Unassigned)

References

Details

When starting my debug build, I see this among the output in my terminal:
{
JavaScript warning: chrome://browser/content/places/controller.js, line 940: yield without a value is deprecated, and illegal in ES6 (use 'yield undefined' instead)
}

This warning was added recently, in bug 885463, FWIW.

mak, looks like you added this 'yield' back in 2011, in this cset for bug 681420:
 http://hg.mozilla.org/mozilla-central/rev/7a8b51e5be41#l1.208

Is "yield undefined" what we want here now?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 887320
You need to log in before you can comment on or make changes to this bug.