Need to disable plugins in Composer (embedding)

VERIFIED FIXED in mozilla1.3beta



17 years ago
5 years ago


(Reporter: Simon Fraser, Assigned: Brade)




Firefox Tracking Flags

(Not tracked)




17 years ago
We need to disable plugins in pages that you load in composer. Corrently, plugins 
load, and respond to click just like they do in a browser window, which is bad.

Comment 1

17 years ago
cc: shrir.

Comment 2

17 years ago
Aren't plugins disabled at the dochshell level?

Comment 3

17 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.0

Comment 4

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
Target Milestone: mozilla1.0 → mozilla1.0.1


16 years ago
Depends on: 125168
I think you really want to use ShouldLoad, and disable the loading of
<object>/<applet>/<embed> elements for that window.  Disabling the load of the
plugin itself seems very much like the wrong thing.

There was a time when <object> and whatnot were all wired up for the content
policy hooks, though that may no longer be the case.  I know that at least
<style> rotted.

Comment 6

16 years ago
Pre-sabbatical bug triage.
Target Milestone: mozilla1.0.1 → mozilla1.2alpha

Comment 7

16 years ago
Not my bag baby.
Assignee: sfraser → kin
OS: Mac System 8.5 → All

Comment 8

16 years ago
*** Bug 159596 has been marked as a duplicate of this bug. ***
Syd: Can someone on the composer team take a look at this one. Kin is
overloaded. Thanks.
Assignee: kin → syd


16 years ago
Keywords: nsbeta1, topembed
Summary: Need to disable plugins in Composer → Need to disable plugins in Composer (embedding)
Target Milestone: mozilla1.2alpha → mozilla1.2final

Comment 10

16 years ago
*** Bug 174378 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
Plussing as per Topembed triage.
Keywords: topembed → topembed+

Comment 12

16 years ago
Assignee: syd → akkana


16 years ago
Target Milestone: mozilla1.2final → mozilla1.3beta

Comment 13

15 years ago
Thought I had a clever way of doing this through a few lines in editor.css, but
it didn't work out.  If I get some time I'll try again, but meanwhile since this
is topembed+ it had better go to someone who's still on the project.
Assignee: akkana → jfrancis

Comment 14

15 years ago
There's a docshell API that can be used to do this. Look at nsIWebBrowserSetup.

Comment 15

15 years ago
Mail/news calls nsIDocShell::SetAllowPlugins.

You'll disable documents and images with the OBJECT tag, but maybe you could do
something like this w/CSS:

  applet, embed, object {
    display: none;

Note that this will not work when bug 90268 is fixed.

Comment 16

15 years ago
Assignee: jfrancis → brade

Comment 17

15 years ago
Resolving this as fixed to get some QA cycles (partial if not complete fix was
checked in as part of bug 186054).

I need to know what the remaining issues are so we can enumerate them or file
new bugs if that is preferable.

Sujay--please test this on all platforms and with a variety of plugins (flash,
quicktime, java, etc)
Last Resolved: 15 years ago
Resolution: --- → FIXED
vrfy'd fixed with 2003.02.19 --plugin content isn't loaded in composer.
You need to log in before you can comment on or make changes to this bug.