screenshot command in developer console says "TypeError: can't access dead object"

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
2 months ago

People

(Reporter: maxime.couasnon, Unassigned)

Tracking

22 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Type 'screenshot' in developer console on any page.


Actual results:

An error occurs : "TypeError: can't access dead object"


Expected results:

Firefox should take a screenshot of my page and briefly display a thumbnail on the down left corner of the screen. It worked perfectly well on Firefox 21 on my computer. I am on MacOS.

Comment 1

5 years ago
WFM with FF22 on Win 7.
Can you test with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Developer Tools: Graphic Commandline and Toolbar

Updated

5 years ago
Flags: needinfo?(maxime.couasnon)
(Reporter)

Comment 2

5 years ago
I created another profile, the screenshot worked well. Now i went back to the normal profile and tried again, now the error has changed: it's "TypeError: window is null" on every page i tried.
Flags: needinfo?(maxime.couasnon)

Comment 3

5 years ago
Maybe add-on issue. Could you try in safe mode: 
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(maxime.couasnon)
(Reporter)

Comment 4

5 years ago
I tried in safe mode, same issue.
Flags: needinfo?(maxime.couasnon)

Comment 5

5 years ago
So maybe you can duplicate your current profile and try to reset it to see if the issue is fixed.
https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems

But honestly, if the issue is fixed with a fresh profile, it's likely invalid.

Comment 6

5 years ago
Env: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0

With some plugins installed I've the same issue with this command, but
in a fresh instalation screenshot command works well.

The command crash for example if the delicius plugin is installed

Comment 7

5 years ago
And in safe mode?
Flags: needinfo?(aetxebeste)

Comment 8

5 years ago
I tried in safe mode and same issue occurs, but when I restart FF in normal mode screenshot command only works in a few times. Later on stops working.

Sorry for my ambiguous answer ;)
Flags: needinfo?(aetxebeste)

Comment 9

5 years ago
(In reply to aetxebeste from comment #8)
> I tried in safe mode and same issue occurs, but when I restart FF in normal
> mode screenshot command only works in a few times. Later on stops working.
> 
> Sorry for my ambiguous answer ;)

And all works normally with a fresh profile, even on a long duration?
Flags: needinfo?(aetxebeste)

Comment 10

5 years ago
Yes it works normally.

When I restart FF in a normal mode, the screenshot commands only works in the firt tab and with the first url.
Flags: needinfo?(aetxebeste)
(Reporter)

Comment 11

5 years ago
I have some fresh information about this issue, each time firefox fails to take a screenshot i get the following message in my OS X terminal:

console.error: 
TypeError
  - prototype TypeError
    - columnNumber = 10
    - fileName = resource://app/modules/devtools/BuiltinCommands.jsm
    - lineNumber = 1671
  - prototype Error
  - prototype Object

Comment 12

5 years ago
It could be related to OSX version of Firefox and another special condition maybe (add-on or something like that). Anyway creating a clean profile fixes the issue.
I have not noticed this issue recently, and the screenshot command has changed heavily after GCLI runAt support.  Please re-open if this is still an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.