Phonebook :: Home :: Embedded text not present in search bar for Internet Explorer 8.

VERIFIED FIXED in 2013-07-25

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sandeep.b, Assigned: julia)

Tracking

other
2013-07-25

Details

(Whiteboard: [kb=1034287] )

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36



Actual results:

Opened the Mozillians home page in Internet Explorer 8 browser. Observed that the search bar did not contain the embedded text "Search for people, groups and more" as was seen in Firefox and Chrome browsers.



Expected results:

The embedded text, if present in the said browser, will be helpful in explaining what the bar does.
(Reporter)

Comment 1

5 years ago
Created attachment 770705 [details]
Screenshots for search bar

Screenshots attached:
1. Screenshot 889777.a shows the search bar in Firefox browser
2. Screenshot 889777.b shows the search bar in Internet Explorer.
Whiteboard: [kb=1034287]
(Assignee)

Comment 2

5 years ago
After doing some testing, it looks as if this bug occurs on IE9 and down. This is because input placeholder text is not supported for these versions of IE (is supported in IE10: https://developer.mozilla.org/en-US/docs/Web/HTML/Element/Input). 

We can use something like the following script to fake the placeholder text: https://github.com/ginader/HTML5-placeholder-polyfill
(Assignee)

Updated

5 years ago
Assignee: nobody → julia
(Assignee)

Comment 3

5 years ago
Pull requested submitted here: https://github.com/mozilla/mozillians/pull/542

Comment 4

5 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/70f852587e4826b70a13a7a514e5ecd8d06c9ace
[Bug 889777] Fix placeholder text so that it displays in <=IE9.

https://github.com/mozilla/mozillians/commit/071319a3052149cb8bada8b905ef25b63d0b8f77
Merge pull request #542 from juliaelman/889777-fix-placeholder-text

[Bug 889777] Fix placeholder text so that it displays in <=IE9.
Bumping to resolve fixed - this is on stage and ready to for verification
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-06-27
Created attachment 772118 [details]
qa - verified on stage

QA verified on stage - the text is present in the search bar for IE 8, IE 9, and IE 10.

Updated

5 years ago
Status: RESOLVED → VERIFIED
Target Milestone: 2013-06-27 → 2013-07-25
You need to log in before you can comment on or make changes to this bug.