[browser] Re-evaluate regular expression (regexp) matching in location/address bar

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: aryx, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 fixed)

Details

(Whiteboard: [sprintready])

Unagi with Gaia 1.1.0.0-prerelease 20130702230206

At the moment, the browser's location bar applies the user input as regular expression. This yields unexpected unexpected page suggestions.

Example:
1. Visit http://www.dwdl.de (has "das medienmagazin") in its title
2. Type "en." into the location bar (e.g. for en.wikipedia.org)
Actual result:
dwdl.de is a suggestion and "das mediENMagazin" highlighted

Furthermore, the performance influence by the regexp should be checked: Typing an 8 character word into the address bar (which doesn't exist in the results) and waiting for the suggestions takes 15+ seconds.
Whiteboard: [sprintready]

Comment 1

5 years ago
Candice Serran deleted the linked story in Pivotal Tracker

Comment 2

5 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/54770916
With the new rocketbar search interface, it is by design that we want to search place and application names. I think this has been solved by the new rocketbar feature in 2.2, but feel free to re-open with additional information i you think otherwise. Regarding the performance issues: we have other bugs filed to address them.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.