Turn off Caret Browsing after closing developer console automatically

RESOLVED WORKSFORME

Status

DevTools
General
RESOLVED WORKSFORME
5 years ago
a month ago

People

(Reporter: ShellHacker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [enhancement], URL)

Attachments

(1 attachment)

Created attachment 770727 [details]
After working on the new Firefox OS website. Closing the console results in caret browsing still being active. An enhancement would be to allow options for closing caret browsing automatically.

Start the developer console by the command Ctrl + Shift + K

Go to the debugger section / style editor, make some edits.
Select the section of the screen, and inspect element (Q)

Make a few changes, and close the console.

Bug #1 : Dock it to the side. Then close it. The webpage reloads. 
        (The reload shouldn't be happening)

Bug #2 (Occurs sometimes) : When console is at the bottom, turn on caret browsing. 

(Most developers use this feature to copy text information on the browser since its easier)

When console is closed, the caret browsing still remains active.
====================================================

What could be done

1. Give a settings option for choosing caret browsing to automatically turn off when Console is closed.
(Reporter)

Updated

5 years ago
Whiteboard: [enhancement]

Updated

5 years ago
Component: Web Components → Developer Tools
Product: Developer Ecosystem → Firefox

Comment 1

a year ago
With the Caret Browsing button (F7) available, will it be a stretch to implement this feature now?
Flags: needinfo?(sudheesh1995)
(Reporter)

Comment 2

8 months ago
Unable to reproduce anymore. I think this can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(sudheesh1995)
Resolution: --- → WORKSFORME

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.