strings.xml.in: Apostrophe not preceded by \ (in A' tòiseachadh le Firefox)

RESOLVED WONTFIX

Status

Mozilla Localizations
gd / Scottish Gaelic
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: nalexander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Android gd language repacks are failing with

04:51:28    ERROR -  res/values/strings.xml:824: error: Apostrophe not preceded by \ (in A' tòiseachadh le Firefox)

Relevant log at https://tbpl.mozilla.org/php/getParsedLog.php?id=24880965#error6

Finding a regression range will be challenging since Android language repacks were broken for quite a long time and just restored by Bug 887115; please accept my apologies.

Comment 1

5 years ago
This doesn't seem to be present in Firefox 23 strings, do you have more clues that could help us, like an entity name?
Flags: needinfo?(nalexander)
(In reply to Dwayne Bailey from comment #1)
> This doesn't seem to be present in Firefox 23 strings, do you have more
> clues that could help us, like an entity name?

It's

# LOCALIZATION NOTE (bookmarks_aboutHome):
# link title for about:home
#define bookmarks_aboutHome A' tòiseachadh le Firefox

from

http://hg.mozilla.org/l10n-central/gd/file/e24ff7030420/mobile/profile/bookmarks.inc#l28
Flags: needinfo?(nalexander)

Comment 3

4 years ago
(In reply to Nick Alexander :nalexander from comment #2)
> (In reply to Dwayne Bailey from comment #1)
> > This doesn't seem to be present in Firefox 23 strings, do you have more
> > clues that could help us, like an entity name?
> 
> It's
> 
> # LOCALIZATION NOTE (bookmarks_aboutHome):
> # link title for about:home
> #define bookmarks_aboutHome A' tòiseachadh le Firefox
> 
> from
> 
> http://hg.mozilla.org/l10n-central/gd/file/e24ff7030420/mobile/profile/
> bookmarks.inc#l28

OK this is on central and we only translate GD in Aurora

The issue is not present in https://hg.mozilla.org/releases/l10n/mozilla-aurora/gd/file/8da260ef9198/mobile/profile/bookmarks.inc and neither in mozilla-beta or mozilla-release.  Just on central, and my guess, based on dates, that this is a really old translation.

So I'm not sure what would need to be done, but we're probably the least able to easily fix that.  So I hope you can fix it by just removing that string.

Summary rant. This is the most idiotic part of localising for Android, expecting humans to follow some random rule when a machine can do the job properly and better.  I'm sorry that we've all had to waste so much time on a bad implementation decision :)

Comment 4

4 years ago
This only impacts Central not users
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.