printing cancel crashes

VERIFIED DUPLICATE of bug 83805

Status

()

--
critical
VERIFIED DUPLICATE of bug 83805
18 years ago
18 years ago

People

(Reporter: coz, Assigned: dcone)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628
BuildID:    20010628

Canceling print dialog opened by javascript, and then trying to reprint the same
page crashes the browser.

Reproducible: Always
Steps to Reproduce:
1.Mozilla tries to print the page by window.print(). Cancel print-dialog.

2.Get off the page that tries to print itself.

3.Get back to the page. Mozilla crashes before showing print-dialog.

Actual Results:  Mozilla crashes.

Expected Results:  Bring up the print dialog.

Printer was HP-4050N, used as a network printer. HP-1100 also tried, same results.

Comment 1

18 years ago
Reporter can you find a testcase for us where this occurs? Also do you have the
talkback id from the crash?
Keywords: crash
(Reporter)

Comment 2

18 years ago
I have made test page to demonstrate this process:

http://info.pihla.net/test.html

Press the button. A new window opens and opens print dialog.
Cancel the dialog.

Press the button again. Mozilla crashes...
(Reporter)

Comment 3

18 years ago
Talkback application doesn't start when the crash happens. Talkback is installed
and should work.

This is what Windows says (in Finnish, but you should be able to figure it out :) )

MOZILLA aiheutti keskeytyksen 10H moduulissa GKLAYOUT.DLL muistipaikassa
0167:60399911.
Rekisterit:
EAX=01518ab0 CS=0167 EIP=60399911 EFLGS=00010246
EBX=0000000f SS=016f ESP=0068c08c EBP=0068c0fc
ECX=0068c0d0 DS=016f ESI=015187f8 FS=2a37
EDX=0068c0e4 ES=016f EDI=00000000 GS=0000
Tavut muistipaikassa CS:EIP:
d9 5e 44 8b 08 dd d8 ff 51 18 83 7d e8 00 7e 45 
Pinon vedos:
01518ab0 0068de44 0068c0e4 00000000 00000001 015187f8 02005770 0068de44 0068c1c8
6033190c 02010980 015187c4 60ec7389 00000000 00000000 00000000 

Comment 4

18 years ago
I just tried the steps indicated here:

1) Jump to the URL: http://info.pihla.net/test.html
2) Press the button
3) Cancel the dialog
4) Press the button again (the print dialog comes up at this point)

I don't see a crash at this point? what steps am I missing?
(Reporter)

Comment 5

18 years ago
That is how it works for me. Have you closed the pop-up window?
(Reporter)

Comment 6

18 years ago
Tried that on my home computer too ( Netscape 6.1 Pre) and it crashes every time
too. It seems to require indeed that you close the pop-up window "Just
testing..." before pressing the button again...

Comment 7

18 years ago
can you please indicate exact steps to arrive at the crash?

the following is not enough:

"Press the button. A new window opens and opens print dialog.
Cancel the dialog.

Press the button again. Mozilla crashes..."

because when I try the above, I don't crash.
(Reporter)

Comment 8

18 years ago
OK, the steps again:

1. Go to http://info.pihla.net/test.html
2. Press the button.
3. A new window opens. It tries to print itself. When the print dialog opens
press 'cancel'.
4. Close the popup windows (important!).
5. Press again the button.
6. Crash!

Could this bug be solved in post-0.9.2 releases?

I have tried this with two configurations:
1) Netscape 6.1 Pre, Windows ME, HP Deskjet 640C
2) Mozilla 0.9.2, Windows 98, HP Laserjet 4050N and HP LJ 1100
(Reporter)

Comment 9

18 years ago
Tried again with Xerox Document Centre 50 Color. Crashes!

Comment 10

18 years ago
I tried the exact steps listed...I don't crash.

After step 5) "Press Again the button" , I get the print dialog again.

I don't crash...

I'm on Win 98.

please download latest build and try again..

Don, can you reproduce this?
(Reporter)

Comment 11

18 years ago
Created attachment 41388 [details]
Talkback details
(Reporter)

Comment 12

18 years ago
Downloaded the latest build. It still crashes. Fortunately Talback works, so I
submitted the report as an attachment.
(Reporter)

Comment 13

18 years ago
This could be related to bugs 89284 (crash entering preferences after canceling
print job) and 84780 (NETSCP6 caused exception 10H in GKLAYOUT.DLL). I get
crashes on those too.

Seems to me that canceling print job just makes Mozilla crash on some
configurations. Maybe you could find something in common...



Comment 14

18 years ago
Actually the attachment doesnt help much we need the ID # from a crash if you
have one :)
(Reporter)

Comment 15

18 years ago
Downloaded the latest version again 2001072208. Crashing continues.

Here's the ID#:
TB33218347M

Comment 16

18 years ago
Incident ID 33218347
Stack Signature nsSliderFrame::DoLayout ecf605bb
Bug ID
Trigger Time 2001-07-22 23:19:19
User Comments (Marked already as bug 88990)
Build ID 2001072210
Product ID MozillaTrunk
Platform ID Win32
Stack Trace
nsSliderFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSliderFrame.cpp, line 411]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsPopupSetFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsPopupSetFrame.cpp, line 292]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsMenuFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 865]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 986]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 421]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 553]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 980] 

Comment 17

18 years ago

*** This bug has been marked as a duplicate of 83805 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 18

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.