Crashes after the splash screen on Win2K

RESOLVED DUPLICATE of bug 86644

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 86644
17 years ago
17 years ago

People

(Reporter: Isaac Han, Assigned: karnaze (gone))

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Whenever I run browser (mozilla.exe Version 0.9.2) the splash screen comes up 
then it crashes. I can't see talkback window when it crashes even it's talkback 
enabled version of Mozilla. I can reproduce it anytime. When I run Mail it 
crashes too without the splash screen.

Note, I uninstalled previous version of Mozilla (0.9.1) before I installed 
Mozilla Version 0.9.2 

File : mozilla-win32-0.9.2-installer.exe 8,523 KB Talkback enabled version.
OS: Windows 2000 Professional Edition 5.00.2195 (Service Park 2)
RAM: 128K

I am not able to find out Build ID but Setup Program show this number.
Mozilla (5.0.0.0.2.2001062817) Setup 

Thoses are logs when mozilla.exe crashes.

### Logfile
Application exception occurred:
        App: mozilla.exe (pid=1124)
        When: 2001/07/02 @ 22:34:27.551
        Exception number: c0000005 (access violation)

*----> System Information <----*
        Computer Name: COMPAQ
        User Name: User
        Number of Processors: 1
        Processor Type: x86 Family 6 Model 7 Stepping 3
        Windows 2000 Version: 5.0
        Current Build: 2195
        Service Pack: 2
        Current Type: Uniprocessor Free
        Registered Organization: 
        Registered Owner: compaquser

*----> Task List <----*
   0 Idle.exe
   8 System.exe
 140 SMSS.exe
 164 CSRSS.exe
 184 WINLOGON.exe
 212 SERVICES.exe
 224 LSASS.exe
 396 svchost.exe
 424 SPOOLSV.exe
 456 svchost.exe
 492 regsvc.exe
 508 mstask.exe
 544 tlntsvr.exe
 604 WinMgmt.exe
 884 explorer.exe
 752 winampa.exe
 812 DAP.exe
 792 internat.exe
 796 msmsgs.exe
 784 iexplore.exe
 972 mdm.exe
 196 SecureCRT.exe
 304 AcroRd32.exe
 852 iexplore.exe
 596 hh.exe
1156 DRWTSN32.exe
1124 mozilla.exe
1108 DRWTSN32.exe
   0 _Total.exe

(00400000 - 00456000) 
(77F80000 - 77FFB000) 
(60EC0000 - 60F26000) 
(60D90000 - 60D99000) 
(60E00000 - 60E24000) 
(77DB0000 - 77E0B000) 
(77E80000 - 77F35000) 
(77D40000 - 77DB0000) 
(75050000 - 75058000) 
(75030000 - 75043000) 
(78000000 - 78046000) 
(75020000 - 75028000) 
(60E90000 - 60E97000) 
(60EA0000 - 60EA6000) 
(782F0000 - 78532000) 
(77F40000 - 77F7C000) 
(77E10000 - 77E74000) 
(77C70000 - 77CBA000) 
(77B50000 - 77BD9000) 
(77A50000 - 77B46000) 
(75E60000 - 75E7A000) 
(6E420000 - 6E426000) 
(73400000 - 73418000) 
(605B0000 - 605B8000) 
(60CC0000 - 60D0C000) 
(60190000 - 6019B000) 
(600C0000 - 600CD000) 
(60A50000 - 60A5E000) 
(60C50000 - 60C5C000) 
(60BE0000 - 60C02000) 
(600A0000 - 600B0000) 
(60480000 - 604A0000) 
(60C70000 - 60C84000) 
(60C90000 - 60C9C000) 
(76B30000 - 76B6E000) 
(779B0000 - 77A4B000) 
(77570000 - 775A0000) 
(60980000 - 60997000) 
(60970000 - 6097C000) 
(775A0000 - 77625000) 
(77840000 - 7787C000) 
(770C0000 - 770E3000) 
(607C0000 - 60802000) 
(60F40000 - 60F4C000) 
(74FD0000 - 74FEF000) 
(75010000 - 75017000) 
(60AC0000 - 60AD3000) 
(609E0000 - 609E8000) 
(600F0000 - 600FF000) 
(60410000 - 6044A000) 
(60A40000 - 60A49000) 
(60B50000 - 60B5B000) 
(60300000 - 6031C000) 
(60110000 - 60125000) 
(600B0000 - 600BC000) 
(60580000 - 605A1000) 
(608B0000 - 60956000) 
(601D0000 - 602FC000) 
(60850000 - 6085C000) 
(604D0000 - 604D9000) 
(60570000 - 60579000) 
(60E50000 - 60E81000) 
(608A0000 - 608AA000) 
(60D10000 - 60D21000) 
(60450000 - 60468000) 
(77820000 - 77827000) 
(759B0000 - 759B6000) 
(60620000 - 60626000) 
(60060000 - 60095000) 
(60B70000 - 60B81000) 
(60320000 - 60402000) 
(60470000 - 60480000) 

State Dump for Thread Id 0x468

eax=00000000 ebx=01c9ae10 ecx=0012f6d0 edx=0012f6cc esi=00000000 edi=01c96b10
eip=60362f09 esp=0012f64c ebp=0012f6e0 iopl=0         nv up ei pl zr na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00000246


function: nsIPresShell::GetVerifyReflowFlags

### End of Logfile

Thanks.
(Reporter)

Comment 1

17 years ago
Sorry. It was not talkback enabled version.

Comment 2

17 years ago
Can you please test a nightly talkback.zip build and report back with the
Talkback ID. Thanks.

Comment 3

17 years ago
Moving to correct component based on info we have. Still need a talkback id
though or a backtrace
Severity: blocker → critical
Component: Browser-General → Layout
Keywords: crash, stackneeded
(Reporter)

Comment 4

17 years ago
Two Incident IDs:

TB32504238E
TB32504078E

I am not quite sure those are something you called 'Talkback ID'.
I sent two feedbacks.

Comment 5

17 years ago
Yes, Thanks!. Both crashes look identical. Talkback report below.

Incident ID 32504078
Stack Signature nsCSSFrameConstructor::ConstructDocElementFrame 3f4ee9a3
Bug ID
Trigger Time 2001-07-04 01:04:40
User Comments Bug ID: 88994
Build ID 2001061809
Product ID MozillaTrunk
Platform ID Win32
Stack Trace
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3320]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8469]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1106]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2546]
HTMLContentSink::StartLayout
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3511]
HTMLContentSink::OpenBody
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 2885]
CNavDTD::OpenBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line
3127]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3378]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1316]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1721]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 901]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 544]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1994]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1873]
nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2353]
nsDocumentOpenInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 255]
nsStreamIOChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 461]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 161]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 418]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1146]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1440]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1458]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: doronr → petersen

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 86644 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.