Initial attempt to purchase a paid app failed with "something went wrong"

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: andy+bugzilla)

Tracking

2013-09-17
Points:
---
Bug Flags:
affects-moss +

Details

(Whiteboard: [intermittent])

(Reporter)

Description

5 years ago
steps to reproduce:
1. With country set to Spain, start the purchase of IQ fun in prod
2. Enter PIN

expected behavior:
Bango screen loads

observed behavior:
Error message "something went wrong" flashed and then user returned to the app details page.

This happened around 11.27 am. Since I was getting coffee when this happened, I didn't capture logs :(
(Reporter)

Comment 1

5 years ago
note that second attempt to purchase this app was successful.
We hit this. I'm waiting on access to sentry solitude to see what it was

Jul  3 11:28:07 localhost6.localdomain: [] django.request:ERROR Internal Server Error: /mozpay/wait_to_start :/data/www/marketplace.firefox.com-webpay/venv/lib/python2.6/site-packages/django/core/handlers/base.py:21
5#012Traceback (most recent call last):#012  File "/data/www/marketplace.firefox.com-webpay/venv/lib/python2.6/site-packages/django/core/handlers/base.py", line 111, in get_response#012    response = callback(reques
t, *callback_args, **callback_kwargs)#012  File "/data/www/marketplace.firefox.com-webpay/webpay/webpay/auth/decorators.py", line 32, in wrapper#012    return f(request, *args, **kw)#012  File "/data/www/marketplace
.firefox.com-webpay/venv/lib/python2.6/site-packages/django/views/decorators/http.py", line 41, in inner#012    return func(request, *args, **kwargs)#012  File "/data/www/marketplace.firefox.com-webpay/webpay/webpay
/pay/views.py", line 183, in wait_to_start#012    trans = solitude.get_transaction(request.session['trans_id'])#012  File "/data/www/marketplace.firefox.com-webpay/webpay/lib/solitude/api.py", line 270, in get_trans
action#012    transaction = self.slumber.generic.transaction.get_object(uuid=uuid)#012  File "/data/www/marketplace.firefox.com-webpay/venv/lib/python2.6/site-packages/curling/lib.py", line 151, in get_object#012
 res = self.get(**kw)#012  File "/data/www/marketplace.firefox.com-webpay/venv/lib/python2.6/site-packages/curling/lib.py", line 138, in get#012    params=kwargs)#012  File "/data/www/marketplace.firefox.com-webpay/
venv/lib/python2.6/site-packages/curling/lib.py", line 210, in _request#012    resp = self._call_request(method, url, data, params, hdrs)#012  File "/data/www/marketplace.firefox.com-webpay/venv/lib/python2.6/site-p
ackages/curling/lib.py", line 188, in _call_request#012    params=params, headers=headers)#012  File "/data/www/marketplace.firefox.com-webpay/venv/lib/python2.6/site-packages/requests/sessions.py", line 241, in req
uest#012    r.send(prefetch=prefetch)#012  File "/data/www/marketplace.firefox.com-webpay/ve
Jason, I registered kumar303 on http://sentry.prod.solitude.allizomaws.com/ -- do you need to activate my user?
there was this one line above it in the webpay log (when talking to solitude):

Jul  3 11:28:06 localhost6.localdomain: [] requests.packages.urllib3.connectionpool:WARNING Retrying (0 attempts remain) after connection broken by 'BadStatusLine('',)': /generic/transaction/?uuid=webpay%3Ae6cbe3ac-
eab8-41a6-ac42-f998884aa94b :/data/www/marketplace.firefox.com-webpay/venv/lib/python2.6/site-packages/requests/packages/urllib3/connectionpool.py:468
I got sentry access but I don't see any tracebacks.

Jason, could you take a look at comment #4. We got BadStatusLine when trying to talk to the solitude API. It was an intermittent error but can you see anything in solitude prod that might have caused it?
Flags: needinfo?(jthomas)
This is what I see in the logs during that time: 

Jul  3 18:27:09 10.148.13.190: [] s.proxy:INFO Calling service: bango at https://webservices.bango.com/billingconfiguration/service.asmx :/data/solitude-proxy/www/payments-proxy.firefox.com/releases/1372798701-2013.07.02/solitude/lib/proxy/views.py:53
Jul  3 18:27:13 10.148.9.140: [] s.transaction:INFO Bango transaction: 79 pending :/data/solitude/www/payments.firefox.com/releases/1372798906-2013.07.02/solitude/lib/transactions/models.py:147
Jul  3 18:27:21 10.148.9.139: [] s.bango:INFO Received notification for billing_config_id '20440660': bango_response_code: 'NOT_SUPPORTED'; bango_response_message: 'The user or operator (e.g. MVNO) is not supported by the biller'; bango_trans_id: '0'; moz_transaction: 'webpay:f557db6a-4855-4501-a621-a92f2977ceb4' :/data/solitude/www/payments.firefox.com/releases/1372798906-2013.07.02/solitude/lib/bango/resources/notification.py:36
Jul  3 18:27:56 10.148.9.141: [] s.bango:INFO Bango client call: CreateBillingConfiguration from wsdl: billing :/data/solitude/www/payments.firefox.com/releases/1372798906-2013.07.02/solitude/lib/bango/client.py:88
Jul  3 18:27:56 10.148.13.189: [] s.proxy:INFO Calling service: bango at https://webservices.bango.com/billingconfiguration/service.asmx :/data/solitude-proxy/www/payments-proxy.firefox.com/releases/1372798701-2013.07.02/solitude/lib/proxy/views.py:53
Jul  3 18:27:57 10.148.9.141: [] s.transaction:INFO Bango transaction: 80 pending :/data/solitude/www/payments.firefox.com/releases/1372798906-2013.07.02/solitude/lib/transactions/models.py:147
Jul  3 18:28:34 10.148.9.141: [] s.bango:INFO Bango client call: CreateBillingConfiguration from wsdl: billing :/data/solitude/www/payments.firefox.com/releases/1372798906-2013.07.02/solitude/lib/bango/client.py:88
Jul  3 18:28:34 10.148.13.187: [] s.proxy:INFO Calling service: bango at https://webservices.bango.com/billingconfiguration/service.asmx :/data/solitude-proxy/www/payments-proxy.firefox.com/releases/1372798701-2013.07.02/solitude/lib/proxy/views.py:53
Jul  3 18:28:35 10.148.9.141: [] s.transaction:INFO Bango transaction: 81 pending :/data/solitude/www/payments.firefox.com/releases/1372798906-2013.07.02/solitude/lib/transactions/models.py:147
Jul  3 18:29:27 10.148.9.140: [] s.bango:INFO Received notification for billing_config_id '20440710': bango_response_code: 'OK'; bango_response_message: 'Success'; bango_trans_id: '1201947865'; moz_transaction: 'webpay:88841604-8cd7-4677-b42d-c07e02ff0d8b' :/data/solitude/www/payments.firefox.com/releases/1372798906-2013.07.02/solitude/lib/bango/resources/notification.py:36
Flags: needinfo?(jthomas)
(Reporter)

Updated

5 years ago
Flags: affects-moss+
'bad status line' suggests something wrong at a different level -- do you see any pertinent log messages from gunicorn (or nginx or zeus?) that might indicate a malformed response?
(Assignee)

Updated

5 years ago
Priority: -- → P3
(Assignee)

Updated

5 years ago
Priority: P3 → P2
Whiteboard: [intermittent]
Version: 1.0 → 1.3
(Assignee)

Updated

5 years ago
Assignee: nobody → amckay
(Assignee)

Updated

5 years ago
Target Milestone: --- → 2013-09-17
(Assignee)

Comment 8

5 years ago
I don't see BadStatusLine at all since we moved solitude in house. Not sure what to do with this now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.