Firefox OS Simulator crashes when attempting to load AAC audio

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: jhopkins, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Navigate to an AAC audio link in the Firefox OS Simulator version 3.0.1 (sample file: https://bugzilla.mozilla.org/attachment.cgi?id=693143)
2. Note that the emulator crashes.

I tried to reproduce on a physical phone but it does not crash using the same steps.

Comment 1

5 years ago
I tried this error with FireFox emulator. Here the AAC file is not listed in the Music/Music2 Application. I tried changing the name of the file to .mp4. This file is listed and it plays fine.

Comment 2

5 years ago
Just checked the comment no 36 from https://bugzilla.mozilla.org/show_bug.cgi?id=859711#c36. It says FxOS doesn't plan to support aac extension file name. 
Better to close this bug.
(Reporter)

Comment 3

5 years ago
Hi, Amitav.  Thanks for investigating further.

When I browse to the sample in comment 0 via the Firefox OS Simulator web browser, the simulator still crashes.
Regardless of whether the .aac file extension is supported, it shouldn't excuse a crash bug, in my opinion.

Comment 4

5 years ago
You are correct, it should not crash, but exit gracefully saying something like "File type not supported".
Can you please let me know how to push the aac file to the simulator. adb does not show simulator in the list of device attached.

Comment 5

5 years ago
I placed the Audio files(.mp3,.aac,.mp4,.m4a,.ogg) in /home/music folder. I could see only .mp3 and .ogg files listed in Music Application. I am able to play only .ogg file, but mp3 playback did'nt work(It also did'nt crash in simulator.). Also as per https://developer.mozilla.org/en/docs/Tools/Firefox_OS_Simulator#Limitations MP3, MP4, WebM, AAC are not yet supported.
Also please let me know how come you got .aac file listed in the Music Application?
(Reporter)

Comment 6

5 years ago
I made the simulator crash by pasting the link in comment 0 into the FirefoxOS Simulator's web browser location bar.  I didn't use the Music application.

Comment 7

5 years ago
Created attachment 823303 [details]
ScreenShot

Screen Shot for AAC download in simulator.

Comment 8

5 years ago
I have been using FireFox version 24 and FireFox Simulator version 4.0. When I pasted the link in comment 0 to Simulator Browser, it downloads the file and saves it to Download folder on my system. 

Kindly check the screen shot in comment 7.
(Reporter)

Comment 9

5 years ago
I tried FirefoxOS Simulator 4.0 via Firefox Nightly (27) and Firefox Release (24) (on OS X 10.7.5) and in both cases the simulator crashed.

I tried again with Firefox Release + Simulator 4.0 on a Windows virtual machine and got the "Save As" dialog as you did.  Could be a Mac-only crash bug.
I believe we're using Mulet for this now, so I'm going to resolve this. If it's still important for someone, feel free to reopen this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.