Add a flag for optionally disabling sources.xml

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: diego, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

192 bytes, text/html
Details
(Reporter)

Description

5 years ago
Patch in github coming up
(Reporter)

Comment 2

5 years ago
Created attachment 772717 [details]
Pull request
Attachment #772717 - Flags: review?(mvines)

Comment 3

5 years ago
What problem is this fixing?
(besides the core manifest problem that Diego is trying to address, an option to disable sources.xml is also nice as that build step runs very slowly on my machine sometimes, 5minutes!, and we don't use it in any way)
(Reporter)

Comment 5

5 years ago
Re: core manifest problem.

|make sources.xml| does not know how to parse certain manifests. For example: it fails to interpret <remove-project> elements.

We could try to patch it. But I think the problem resides on the fact that it tries to parse manifests using its own script. This is IMO *very* error prone and hard to maintain. The patch serves as a quick stopgap, and as m1 mentioned, we don't need this for some builds anyway.

FWIW I think |make sources.xml| needs to be revamped to use |repo manifest -o|. This may not be trivial.
(Reporter)

Updated

5 years ago
Attachment #772717 - Flags: review?(mwu)

Comment 6

5 years ago
Agreed on using repo manifest. We also have automation which depends on sources.xml which may make things trickier if we do try to switch over.

m1, does repo manifest run faster on your machine? It appears to take about a second here. If that's fast enough we can avoid adding another build knob.

Comment 7

5 years ago
Comment on attachment 772717 [details]
Pull request

I don't mind adding this as a stop gap, though I generally do not like adding more build variables to fiddle with since they're not particularly easy to discover.
Attachment #772717 - Flags: review?(mwu) → review+
Running |repo manifest -r| is also a dog run my machine, maybe I don't git-gc often enough or something.
Attachment #772717 - Flags: review?(mvines)
https://github.com/mozilla-b2g/gonk-misc/commit/56f756d207db2a13bb4981edcbb55bc5f28cbdb5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

5 years ago
First try didn't stick. Trying again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 11

5 years ago
Created attachment 791398 [details]
Pull request - v2
Attachment #772717 - Attachment is obsolete: true
Attachment #791398 - Flags: review?(mvines)
Attachment #791398 - Flags: review?(mvines) → review+
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 866606
You need to log in before you can comment on or make changes to this bug.