Closed Bug 890151 Opened 6 years ago Closed 6 years ago

[CB] CH50 message should not be displayed when the Cell Broadcast service is off

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: leo.bugzilla.gaia)

References

Details

(Whiteboard: [TD-56902][LeoVB+])

Attachments

(1 file, 1 obsolete file)

177 bytes, text/html
kaze
: review+
Details
1. Title : CH50 CB message do not display when CB service turn off
2. Precondition : CB service turn on and received CH50 CB message
3. Tester's Action : Settings - Call settings - Turn off CB services - Go to lockscreen
4. Detailed Symptom : display ch50 message
5. Expected : do not receive and display ch50 message
6. Reproducibility: Y
   - Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8. Version Info
Build ID : 20130616070209
GAIA : f2d6ed54a236e6e3b94f0abad9f0dacb8a1cc7b3
GECKO : be276cf55ce160bca09f36d9ca679a2ae20ea7cc
blocking-b2g: --- → leo+
Priority: -- → P1
Whiteboard: [TD-56902]
Target Milestone: --- → 1.1 QE4 (15jul)
Attached file patch (obsolete) —
Attachment #771174 - Flags: review?(kaze)
Attached file patch
update lint error
Attachment #771174 - Attachment is obsolete: true
Attachment #771174 - Flags: review?(kaze)
Attachment #773900 - Flags: review?(kaze)
Assignee: nobody → leo.bugzilla.gaia
Any update or progress on the bug?
Flags: needinfo?(leo.bugzilla.gaia)
(In reply to Preeti Raghunath(:Preeti) from comment #4)
> Any update or progress on the bug?

I uploaded the patch again. Please review.
Flags: needinfo?(leo.bugzilla.gaia)
Summary: [CB] CH50 CB message do not receive and display when CB service turn off → [CB] CH50 message should not be displayed when the Cell Broadcast service is off
Sorry for the late review Hyuna. Rebased and merged on master:
https://github.com/mozilla-b2g/gaia/commit/ad923e915a38394497da682c3024ccc37390b52a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attachment #773900 - Flags: review?(kaze) → review+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 ad923e915a38394497da682c3024ccc37390b52a
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(leo.bugzilla.gaia)
Bug 894196 patch doesn't uplift to v1-train. So this patch occured a merge conflict. Please check.
Depends on: 894196
Flags: needinfo?(leo.bugzilla.gaia)
Whiteboard: [TD-56902] → [TD-56902][LeoVB+]
(In reply to Leo from comment #8)
> Bug 894196 patch doesn't uplift to v1-train. So this patch occured a merge
> conflict. Please check.

What should I check?
Flags: needinfo?(leo.bugzilla.gaia)
(In reply to John Ford [:jhford] -- please use 'needinfo?' instead of a CC from comment #9)
> (In reply to Leo from comment #8)
> Bug 894196 patch doesn't uplift to
> v1-train. So this patch occured a merge
> conflict. Please check.

What
> should I check?

Bug 894196 and Bug 890151 should uplift to v1-train.
The attachment 776154 [details] of Bug 894196 uplifed to master but not lift to v1-train.
So it happen a confilct. Please uplift Bug 894196 patch and Bug 890151.
Flags: needinfo?(leo.bugzilla.gaia)
Uplifted ad923e915a38394497da682c3024ccc37390b52a to:
v1-train: 914a7c748b022d9bab8c8dcd5ebf5acffa93083b
v1.1.0hd: 914a7c748b022d9bab8c8dcd5ebf5acffa93083b
This was backed out with ffe6a8cbbcb9d3459124a16918f6e885aa69297f to see if it was the cause for breaking b2g18.  While the backout hasn't been pushed to v1.1.0hd train, it will be when the next merge happens.
v1-train: 8e26f5e4bbc0a8efe182dbbeabfc175e4502ba90
v1.1.0hd: 8e26f5e4bbc0a8efe182dbbeabfc175e4502ba90
You need to log in before you can comment on or make changes to this bug.