Closed Bug 890176 Opened 7 years ago Closed 7 years ago

[Camera] Filmstrip preview opens even when video recording starts

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Details

(Whiteboard: [TD-57024][LeoVB+])

Attachments

(4 files)

9.90 MB, application/x-rar
Details
9.90 MB, application/x-rar
Details
8.23 MB, application/x-rar
Details
195 bytes, text/html
daleharvey
: review+
Details
1. Title : Filmstrip preview opens even when video recording starts
2. Precondition : camera should be working.
3. Tester's Action : 1. Record a video (start and stop)
                     2. Immediately start recording next video before the filmstrip is shown
                     3. Film strip preview open and Play any video from filmstrip 
 
4. Detailed Symptom (ENG.) : Now the video recording has started and film strip preview is also shown but the filmstrip will be hidden. (please check the attachment). This caused because filmstrip will be hidden (but not the preview) after the video recording started.
5. Expected : Filmstrip should be hidden immediately after pressing recording button without waiting for video recording gets started to avoid opening filmstrip preview.

6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 65e861f5941cab66815a2f79b0bc0a6a0fc8f6fe
9.Personal email id: gjyothiprasad@gmail.com
blocking-b2g: --- → leo+
Priority: -- → P3
Whiteboard: [TD-57024]
attachment is missed.
HI Dale,

I have made changes in the following way:
when ever user presses recording button filmstrip will be hidden. so, there will no chance for user to clck on the filmstrip videos.

Please review the patch.
Attachment #771244 - Flags: review?(dale)
Target Milestone: --- → 1.1 QE4 (15jul)
Comment on attachment 771244 [details]
Pointer to Pull request

Good catch, cheers
Attachment #771244 - Flags: review?(dale) → review+
Merged in: https://github.com/mozilla-b2g/gaia/commit/86217e3a3046add3cb7d2f6513ddba5b3221a835
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Uplifted 86217e3a3046add3cb7d2f6513ddba5b3221a835 to:
v1-train: cc8d90a96c9a0421e6ba6ceb8994b22231fa64cc
Whiteboard: [TD-57024] → [TD-57024][LeoVB+]
v1.1.0hd: cc8d90a96c9a0421e6ba6ceb8994b22231fa64cc
You need to log in before you can comment on or make changes to this bug.