[Settings] black screen displayed when launch Settings app

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: Leo, Assigned: arthurcc)

Tracking

unspecified
1.1 QE4 (15jul)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [LeoVB+])

Attachments

(2 attachments)

99.28 KB, image/pjpeg
Details
4.00 MB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 771212 [details]
screenshot

It's one-time issue and there is no precondition.

When launch Settings app, black screen is displayed and it was pending on that screen.
(Reporter)

Comment 1

5 years ago
* Version info.
Build ID : 20130616070209
GAIA : f2d6ed54a236e6e3b94f0abad9f0dacb8a1cc7b3
GECKO : be276cf55ce160bca09f36d9ca679a2ae20ea7cc
blocking-b2g: --- → leo+
Priority: -- → P1
Target Milestone: --- → 1.1 QE4 (15jul)
What's the reproduce rate?

Comment 3

5 years ago
(In reply to Arthur Chen [:arthurcc] from comment #2)
> What's the reproduce rate?

It's one-time issue.
(Reporter)

Comment 4

5 years ago
Created attachment 772394 [details]
logcat
Thanks for the log.

Does it occur after flashing the phone or restarting the phone?

Comment 6

5 years ago
After flashing the phone, it occur on the speficic device.
Assignee: nobody → arthur.chen
By specific device you meant that the issue can only be reproduce on only one device or all LEO devices?

Comment 8

5 years ago
I know one device. I have not seen this symptom and I can't reproduce.
I cannot reproduce it on my LEO device, either. I've heard that some of you will be in Taipei tomorrow. Is it possible to bring the device with this issue to Taipei?

Comment 10

5 years ago
Test part is in other location so I don't have that device. And he is already out of office. Is not there any problem in log?
When do this crash occur? rendering issue, or not?
CC alive for the transition problem.
It may be a problem in Window Manager about app transitioning.
But if it's not reproducible we merely could do nothing. The log is not helpful here.

Any if you are certain you could repro I could make a logging version of Window Manager for you to test.

Comment 13

5 years ago
If you send me a log patch, I will apply in leo internal version.
Then if this issue reproduce in the next test event and get a log, I will upload the log.

The other case is happened like this. It's also one time issue
Take a picture in Camera App - Press home  button  - enter the gallery app - seleet the taken image - click the Bluetooth Transfer - The black screen is shown and phone is stopped.
Is this a new regression? If not, why was this not caught in earlier testing cycles?
Flags: needinfo?(leo.bugzilla.gaia)
Currently the issue is reproducible only on reporter's phone. We should reconsider if this is really a blocker.
Here's a simple AppWindowMonitor:
https://github.com/alivedise/gaia/commit/6379ce324543f847d8515dbe2626749c51b7e179

Usage:
GAIADIR (app-window-monitor✭)✭ ᐅ adb logcat|grep Dump

Log format:
I/GeckoDump(  108): AppMonitor: [1373600718.508][app://communications.gaiamobile.org/ftu/index.html]
I/GeckoDump(  108):   -> ID: appframe0; Class List: <appWindow fullscreen-app portrait-primary>
I/GeckoDump(  108):   -> z-index: 1; Scale: 0.6; Rotate: 0 deg; CSS Visibility: hidden
I/GeckoDump(  108): AppMonitor: [1373600718.515][app://homescreen.gaiamobile.org]
I/GeckoDump(  108):   -> ID: appframe1; Class List: <appWindow>
I/GeckoDump(  108):   -> z-index: 1; Scale: 0.6; Rotate: 0 deg; CSS Visibility: hidden
I/GeckoDump(  108): AppMonitor: [1373600718.636][app://communications.gaiamobile.org/ftu/index.html]
I/GeckoDump(  108):   -> ID: appframe0; Class List: <appWindow fullscreen-app portrait-primary default-background opening>
I/GeckoDump(  108):   -> z-index: 4; Scale: 0.6; Rotate: 0 deg; CSS Visibility: visible
I/GeckoDump(  108): AppMonitor: [1373600718.794][app://communications.gaiamobile.org/ftu/index.html]
I/GeckoDump(  108):   -> ID: appframe0; Class List: <appWindow fullscreen-app portrait-primary default-background opening active>
I/GeckoDump(  108):   -> z-index: 4; Scale: 1; Rotate: 0 deg; CSS Visibility: visible
I/GeckoDump(  108): AppMonitor: [1373600729.869][app://communications.gaiamobile.org/ftu/index.html]
I/GeckoDump(  108):   -> ID: appframe0; Class List: <appWindow fullscreen-app default-background active>
I/GeckoDump(  108):   -> z-index: 4; Scale: 1; Rotate: 0 deg; CSS Visibility: visible
I/GeckoDump(  108): AppMonitor: [1373600730.607][app://communications.gaiamobile.org/ftu/index.html]
I/GeckoDump(  108):   -> ID: appframe0; Class List: <appWindow fullscreen-app active>
I/GeckoDump(  108):   -> z-index: 4; Scale: 1; Rotate: 0 deg; CSS Visibility: visible

I will try to add this utility into main trunk.

Comment 17

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #14)
> Is this a new regression? If not, why was this not caught in earlier testing
> cycles?

This one time issue and do not reproduce in all devices. It's reproduced on reporter's device. We will apply the app monitoring patch and if I get a log, I will share you.
Flags: needinfo?(leo.bugzilla.gaia)
Not reproducible, therefore not a blocker.
blocking-b2g: leo+ → -
(Reporter)

Updated

5 years ago
Whiteboard: [LeoVB+]
Won't fix as this is not reproducible.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.