Multi-line Input field behaves verry strange, eating lines etc.

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Wilfried Goesgens, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I Entered the folowing lines into the Input-Window:
-----------
I'm writing this under the impressions of loading an old 486 Notebook with 8
Meg's ram with Debian-unstable. <br>
As the package - Database grows and grows, the amount of Memory needed to handle
it also gets larger. <br>
The unstable-Package-Database didn't fit into the poorly measured amount of
memory this machine owns
-> It had consistantly swap parts of the dpkg-programm out to his swap
Partition.<br>
A single dpkg-call (independent on wether to list, install or remove one or more
Packages) took about 30 minutes,
which made the wholy setup procedure a task of more than one day....
<br><br>
But: here is the Idea that came to me:<br>
It is very often that we come into a situation, that a machine is overloaded
with the task of hanling it's own
package-database (take things like <ul>
<li>the old 486 firewalling you from the nasty big internet</li>
<li>the little machine feeding your laser-printer</li>
<li> the old Dec-Station you use as X-Terminal</li>
<li> the second partition you keep on your Disk to create boot-CD's</li>
<li> the embedded-machine to control your washing machine </li>
<li> and last (but surely not least) your PDA ).</li>
</ul>
So: why not distribute the Truck-load of work to machine that would do this in
spare-time, like your Desktop >GHzCpu equipped with 100Megs's of ram?<br><br>

There would have to be something like a net-shared Filesystem on the
Slave-machine to be hooked into the Master-machine, and sort of a Deamon
executing the post-install scripts and so on. (ssh?)
<br><br>
And now to the Boot - CD-Thing: what about a Plex-86 running the
target-installation in non-X mode?
-----------------
if you place your Text-cursor and move it beyond the Text visible at first
sight, go to the end of a row and press Enter. now parts of the Text vanish, but
reapear if you go on with typing.
allso selecting the text with the mouse and moving up and down produces some
verry strange ocurancies.

Comment 1

17 years ago
I've seen this also, when submitting information on the mandrakeforum
http://www.mandrakeforum.com site. Also, when scrolling through the text
pressing the down arrow the cursor will go to the end of the text but not always
be visible as being there. If I scroll through the text with the forward arrow,
the cursor goes to the end of the text and then moves to the start of the text
rather than stopping at the end of the text.
The mouse issue is bug 55233.
The other issue looks like bug 63933 which was marked as a dupe of assigned bug
74383.

Comment 3

17 years ago
This appears to be solved with the latest Textarea fixes. Reporter, can you
please reproduce this on a current nightly please? I'd like to mark this WFM.
(Reporter)

Comment 4

17 years ago
well, lets see. ok, the scrollbar appears, as I type the first letter, its size
is correct, and its collor is like the theme says, this is cool! 
as I type on nothing strange happens so far,
but
I 
Have to  now I Paste some text
type  now I Paste some text
some
more now I Paste some text
text now I Paste some text
to 
get  now I Paste some text
it scrolling.
now I move the Cursor Up, And down again, and, just a minute it seems to work
well.now I Paste some text
Ah, I don't know if it's just me, but it seems like pasting text after receiving
Focus back doesn't calc the right line, could you check that? Pop up an XTerm on
another Desk, Navigator in Full-Screen, zap back to the Navigator Desk, and
place the mouse-cursor over the text-box, and paste. The text doesn't always hit
the box on the line corrosponding to the mouse cursor. 
man, there is something more strange remaining. Position the Cursor on the line
start at the End of the Text, move up to the top, move back down, try to move on
left, and ZAP! you're back at the top...
But, good work though.
(Reporter)

Comment 5

17 years ago
well, lets see. ok, the scrollbar appears, as I type the first letter, its size 
NO, IT APPEARS AS IT'S NEEDED.
is correct, and its collor is like the theme says, this is cool! 
as I type on nothing strange happens so far,
but
I 
Have to now I Paste some text
type 
some
more
text
to 
getnow I Paste some text
it scrolling.
now I move the Cursor Up, And down again, and, just a minute it seems to work
well.now I Paste some text
 oh wait, there is something strange. If I paste text, go at the end of It,(the
Cursor remains in the same Line) and start typing something, and the Cursor and
my new Text zap instantly into the next line, way of strange.
The next thingnow I Paste some text is, The wood-measuremets on the scroll-Tumbs
turned by 90 degrees. 
Oh, WAIT, THIS WAS THE WRON BROWSER-WINDOW! I'm sorry. Forget about the
Cut+Paste-Issue.
Allso the Cursor-Navigation works well, but wait, <Page UP/DOWN> doesn't move
the Cursor! Just the scroll-bar.
But One thing: How is the Size of the Area calculated? there Is some Nasty 3
pixel wide rest of Text, shouldn't be only full lines drawn?

Comment 6

17 years ago
Page up/down issue is filed as bug 4302

Thank you for testing Mozilla.

Marking as WFM per reporters comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPEME

Comment 7

17 years ago
This bug is silmilar ro bug 4302

Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.