Chatzilla login attempt flood

RESOLVED WORKSFORME

Status

Other Applications
ChatZilla
--
trivial
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Larry Lade, Assigned: Robert Ginda)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010702
BuildID:    2001070203

First time launching Chatzilla after installing 2001070203, clicked moznet,
Attempting to connect to... messages fill screen and push scrollbar, mozilla
stops responding. Manually terminated chatzilla with Ctrl-Alt-Del.
Upon trying to connect to moznet again, works properly but reports that I've
been banned from moznet due to WinGate proxy (???).

Connects to other irc networks without issue now.


Reproducible: Couldn't Reproduce


I've got oidentd running on my gateway, with record of numerous sequential ident
checks coinciding with the login flood.
(Assignee)

Comment 1

17 years ago
irc.mozilla.org bans anyone who connects from an IP with a wingate proxy port
open to the internet, it's not chatzilla's fault.  I don't know the port number
off hand :(

As far as your "connect flood" is concerned, I'll need more information if I'm
going to do anything about it.  ChatZilla only makes a second (and Nth) attempt
to connect after a previous attempt fails.  It'd help to know why the connection
failed.  Chatzilla shouldn't lock up Mozilla under any circumstances, but
there's not enough information in the bug report for me to do anything about it.

You can try inducing a large number of failed connects by specifying an invalid
host/port with the server command, for example...

/server irc.foo.bar
/server irc.mozilla.org 12345

Either of these should case ChatZilla to attempt to connect multiple (20) times,
and fail each time.  I'd be curious to find out of Mozilla freezes for you in
this situation.

Please repoen the bug if you can reproduce the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
Attempting to connect to nonexistant hosts generates the correct (I assume) error:

[INFO]Attempting to connect to ``irc.foo.bar''. Use /cancel to abort.
[INFO]Connecting to irc.foo.bar:6667, attempt 1 of 20...
[ERROR]Could not connect to irc.foo.bar (irc.foo.bar).
[INFO]Unknown host: irc.foo.bar

The thing about the bug in question is that it did NOT provide any information
about the reconnects at all. It just repeated a single line down the whole page.
I think it was the "Attempting... "line but I'm not certain since I haven't been
able to reproduce. It was very obviously errant behavior, but unfortunately (for
troubleshooting purposes) chatzilla has been behaving correctly since.
I've always previously been able to connect to irc.mozilla.org via this system
with chatzilla without problem, but I can't match the reported time of ban
(10.43) with the time of this error (~ 4 am) so I'll look elsewhere in regards
to that.

I bugged this out of concern that chatzilla might be generating, under rare
circumstances, what would look like a DoS attack to an irc server. And also in
case anybody else stumbled across it. I'll reopen if I'm able to reproduce, and
try to include a screenshot.
(Assignee)

Comment 3

17 years ago
Sometimes chatzilla spews messages faster than the rendering engine can update
the  display.  When this happens, it can look like the same message has been
repeated multiple times.  Try the /testdisplay command (it spews the mode when
used on an irc channel, don't worry, the text isn't actualy sent to the channel)
when your system is under heavy load to see the effect.

My guess (hope) is that the attempt to connect->wingate ban->connect again cycle
was faster than the rendering engine could handle.
(Reporter)

Comment 4

17 years ago
The error did seem consistent with a graphic/render glitch, which is decidedly
less troublesome.

Completely unrelated to this bug then: I can't find the slightest administrative
contact information for irc.mozilla.org anywhere. Any idea who I should e-mail
in regards to the WinGate ban thing?
Severity: blocker → trivial
(Assignee)

Comment 5

17 years ago
pavlov@netscape.com is the guy who set up the wingate detection script.
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.