Closed Bug 890245 Opened 8 years ago Closed 8 years ago

Addons icon keep disappearing after restart of browser

Categories

(Firefox :: Toolbars and Customization, defect)

25 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: kevinkan.mh, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: addon-compat, Whiteboard: [Australis:P2])

Attachments

(2 files)

Attached image beforerestart.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130702 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130702040201

Steps to reproduce:

1. installed HellBoy Firewall addon and DownloadThemAll addon
2. closed the browser
3. restarted the browser


Actual results:

hellboy firewall and downloadthemall icon which i put at the side of awesome bar was gone


Expected results:

the icons should have never disappeared
Keywords: addon-compat
Whiteboard: [Australis:P2]
Attached image afterrestart.jpg
Comment on attachment 771312 [details]
afterrestart.jpg

i actually removed the icons myself in this pic becoz i just wanna show how it looks like after restart and becoz i can't quit my browser while in a middle of submitting a bug
Attachment #771312 - Attachment description: i removed the icons in this pic becoz i cannot quit my browser while submitting the bug → afterrestart.jpg
Marked P2 on the supposition that these add-ons aren't doing anything crazy, and there's something in our customizableUI code that means we're not restoring them properly. This might not be a very solid assumption. I don't have time to look right now, but I can have a closer look once we've worked through our performance blockers.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Component: Add-ons Manager → Toolbars and Customization
Product: Toolkit → Firefox
Trying to reproduce this. I can see the hellboy firewall icon going away, but haven't been able to investigate why that is yet. I can't reproduce the issue with DTA; once I've added the icons (all 4 of them...) to the toolbar, before the awesomebar, they all stay there just fine.
The Hellboy issue might go away after fixing bug 887438, but it's possible it'll require more work on the add-on author's part to make this work. Marking the dependency for now, and then we can resolve as appropriate if/when that bug lands.
Status: UNCONFIRMED → NEW
Depends on: 887438
Ever confirmed: true
Egh. The add-on in question disappeared off addons.mozilla.org. :-\

I'm faaaaaiiiirly sure this got fixed, so I'm going to mark as WFM. Please reopen if you can still reproduce with other add-ons. Thank you! :-)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.