Addons icon keep disappearing after restart of browser

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: RyanTheUXLover, Unassigned)

Tracking

(Blocks: 1 bug, {addon-compat})

25 Branch
x86
Windows 7
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P2])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 771311 [details]
beforerestart.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130702 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130702040201

Steps to reproduce:

1. installed HellBoy Firewall addon and DownloadThemAll addon
2. closed the browser
3. restarted the browser


Actual results:

hellboy firewall and downloadthemall icon which i put at the side of awesome bar was gone


Expected results:

the icons should have never disappeared

Updated

5 years ago
Blocks: 872617
Keywords: addon-compat
Whiteboard: [Australis:P2]
(Reporter)

Comment 1

5 years ago
Created attachment 771312 [details]
afterrestart.jpg
(Reporter)

Comment 2

5 years ago
Comment on attachment 771312 [details]
afterrestart.jpg

i actually removed the icons myself in this pic becoz i just wanna show how it looks like after restart and becoz i can't quit my browser while in a middle of submitting a bug
Attachment #771312 - Attachment description: i removed the icons in this pic becoz i cannot quit my browser while submitting the bug → afterrestart.jpg

Comment 3

5 years ago
Marked P2 on the supposition that these add-ons aren't doing anything crazy, and there's something in our customizableUI code that means we're not restoring them properly. This might not be a very solid assumption. I don't have time to look right now, but I can have a closer look once we've worked through our performance blockers.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit

Updated

5 years ago
Component: Add-ons Manager → Toolbars and Customization
Product: Toolkit → Firefox

Comment 4

5 years ago
Trying to reproduce this. I can see the hellboy firewall icon going away, but haven't been able to investigate why that is yet. I can't reproduce the issue with DTA; once I've added the icons (all 4 of them...) to the toolbar, before the awesomebar, they all stay there just fine.

Comment 5

5 years ago
The Hellboy issue might go away after fixing bug 887438, but it's possible it'll require more work on the add-on author's part to make this work. Marking the dependency for now, and then we can resolve as appropriate if/when that bug lands.
Status: UNCONFIRMED → NEW
Depends on: 887438
Ever confirmed: true

Comment 6

5 years ago
Egh. The add-on in question disappeared off addons.mozilla.org. :-\

I'm faaaaaiiiirly sure this got fixed, so I'm going to mark as WFM. Please reopen if you can still reproduce with other add-ons. Thank you! :-)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.