All users were logged out of Bugzilla on October 13th, 2018

Mozilla-0.9.2 segfaults

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
18 years ago
17 years ago

People

(Reporter: esbjerg, Assigned: dougt)

Tracking

({crash})

Trunk
Sun
Solaris
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
On my Enterprise 250 running Solaris 8:
[esbjerg@ripley]> /opt/mozilla/mozilla
/opt/mozilla/run-mozilla.sh /opt/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/opt/mozilla
 
LD_LIBRARY_PATH=/opt/mozilla:/opt/mozilla/plugins:/usr/local/lib:/opt/gnome/lib
     LIBRARY_PATH=/opt/mozilla:/opt/mozilla/components
       SHLIB_PATH=/opt/mozilla
          LIBPATH=/opt/mozilla
       ADDON_PATH=/opt/mozilla
      MOZ_PROGRAM=/opt/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
Segmentation Fault - core dumped
(Reporter)

Comment 1

18 years ago
Forgot to tell it's the binary version of 0.9.2 from mozilla.org.
When using the 0.9.2 build from mozilla.org it will crash at startup with one of
the following error messages:

- Illegal Instruction (most of the cases)
- Bus Error (sometimes)
- Segmentation fault (occasionally)

Same for all nightly builds that I have tried.
Installing gtk+-1.2.10 did not help. Maybe this is related to Bug 88205.
For some (but not all) users it helped to delete the ~/.mozilla directory.

Updated

18 years ago
Keywords: crash

Comment 4

18 years ago
Not a blocker
Severity: blocker → critical
(Reporter)

Comment 5

18 years ago
It does not help to remove the ~/.mozilla directory.

Comment 6

18 years ago
We need a stacktrace or talkback id for us to do anything with this.
Keywords: stackneeded
(Reporter)

Comment 7

18 years ago
A pstack on the core-file:
[esbjerg@ripley]> pstack core
core 'core' of 27455:   /opt/mozilla/mozilla-bin
-----------------  lwp# 1 / thread# 1  --------------------
 ff17c72c Shutdown__22nsComponentManagerImpl (0, ff164840, 2ccb4, feb3f0b8, 
3f8, 1) + 10
 ff14e444 NS_ShutdownXPCOM__FP17nsIServiceManager (0, ffbef0a4, 0, 5, 100d4, 
0) + 328
 00016f60 main     (0, ffbef0a4, ffbef0ac, 2c878, 0, 0) + 178
 00012fec _start   (0, 0, 0, 0, 0, 0) + 5c
-----------------  lwp# 2 / thread# 2  --------------------
 fe9ce914 _dynamiclwps (0, 0, 0, 0, 0, 0)
-----------------  lwp# 3  --------------------------------
 fe9ca438 _lwp_start (0, 0, 0, 0, 0, 0)
--------------------------  thread# 3  --------------------
 fe9cd8e8 _reap_wait (fe9f2a30, 209f4, 0, fe9ee000, 0, 0) + 38
 fe9cd640 _reaper  (fe9eee58, fe9f4798, fe9f2a30, fe9eee30, 1, fe400000) + 38
 fe9dbb34 _thread_start (0, 0, 0, 0, 0, 0) + 40

I don't know how to gid the talkback id. Perhaps you could tell me which file 
it's in.
Keywords: stackneeded

Comment 8

18 years ago
Marking nEW.
Status: UNCONFIRMED → NEW
Component: Browser-General → XPCOM
Ever confirmed: true

Comment 9

18 years ago
reassign
Assignee: asa → kandrot
QA Contact: doronr → scc

Comment 10

18 years ago
Not really enough info in this bug so far to work on it.  Which line does this
stack dump relate to?  Is the Shutdown +10, mean that it crashed at the 10th
line or the 10th assembly instruction?  The fact that it crashed immediately,
and in the shutdown code, but at launch time, says to me that the program was
quitting for some other reason.  If so, fixing this crash will solve the
immediate problem of the crash, but not allow the program to run, since it was
already in the exit code at this point.  Was there any other symptoms?  Did
anything draw on the screen?  Thanks.

(I'm guessing, based on the info I have so far, that one of the shutdown objects
had not been created before it tried to suddenly quit, and it was assumed that
it was created.  If more info proves this wrong or right, I will act upon that.)
(Reporter)

Comment 11

18 years ago
Answer to Edward Kandrot. Mozilla crashes immediately. It's running on a 
Solaris 8 system with all the patches that has been released. For the record. 
It's a Sun Ray system which means I'm running Mozilla on a terminal. I'm 
afraid I'm out of info unless you have some specific questions.

Comment 12

18 years ago
If it crashes immediately, based on the limited stack trace posted in this bug,
I would say that mozilla will launch then quit immediately (but without the seg
fault once that is fixed).  There is a problem that assumes certain objects are
created and are there for shutdown, which is something I will investigate.  I
propose that there is another problem, which needs a bug against it, that it
will not run at all on your system.  I will look into this crash, and post a fix
for it when I fix it.
Status: NEW → ASSIGNED

Comment 13

18 years ago
I have exactly the same problem and am also on Solaris 8 and a SunRay. Would the
truss output help to determine exactly how far the program got? Let me know and
I can add it.
(Assignee)

Comment 14

17 years ago
reassign all kandrot xpcom bug.
Assignee: kandrot → dougt
Status: ASSIGNED → NEW
(Assignee)

Comment 15

17 years ago
Does this still happen with the current trunk?
(Reporter)

Comment 16

17 years ago
Downloaded a nightly build a couple of days ago. It is _very_ slow but it starts. Build ID: 2001082622From the startup:[esbjerg@ripley]> /opt/mozilla/mozilla/opt/mozilla/run-mozilla.sh /opt/mozilla/mozilla-binMOZILLA_FIVE_HOME=/opt/mozilla  LD_LIBRARY_PATH=/opt/mozilla:/opt/mozilla/plugins:/usr/local/lib:/opt/gnome/lib     LIBRARY_PATH=/opt/mozilla:/opt/mozilla/components       SHLIB_PATH=/opt/mozilla          LIBPATH=/opt/mozilla       ADDON_PATH=/opt/mozilla      MOZ_PROGRAM=/opt/mozilla/mozilla-bin      MOZ_TOOLKIT=        moz_debug=0     moz_debugger=Gdk-WARNING **: shmat failed!Gdk-WARNING **: shmat failed!Gdk-WARNING **: Missing charsets in FontSet creationGdk-WARNING **:     ISO8859-15The missing fontset gets printed on stderr whenever the mozilla-window is active.For the record. I have Ximian Gnome 1.2 installed which is where gtk etc. comes from.
(Assignee)

Comment 17

17 years ago
Sven, marking bug wontfix. 0.9.2 is long gone.  If it still crashes for you,
please reopen and attach a stack trace.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.