collusion 0.27 add-on doesn't appear to work ff21 or ff22

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: jemuse3, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

installed collusion 0.27 add-on in ff21 and ff22


Actual results:

there is no collusion icon on the add-on bar


Expected results:

a collusion icon on the add-on bar

Comment 1

5 years ago
WFM on install with 2013-07-08-03-11-14-mozilla-central-firefox-25.0a1.ru.linux-x86_64,  23.0 Beta, 22.0.

But (with 22.0) if I remove it and undo removal, the icon doesn't re-appear.

Also, with 23.0 Beta and the Nightly, if I use it and then remove, Navigation Bar disappears and cannot be enabled until restart.
Component: Untriaged → Extension Compatibility

Comment 2

5 years ago
> Navigation Bar disappears

As in, does not re-appear after about:addons.
WFM installing it on a fresh profile on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
buildId: 20130618035212
(Reporter)

Comment 4

5 years ago
my issue has been resolved.  collusion 0.27 worked out of the box with a fresh install of ff19 but did not appear to work with fresh installs of ff20, ff21 and ff22.  after unchecking "always use private browsing" setting, collusion 0.27 does work with ff20, ff21 and ff22.  whether private browsing became the default behaviour with ff20 or was the result of my mucking with settings is unclear.
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 5

5 years ago
I'm not sure if this question is still open as I don't understand the post by jemuse3 at 2013-07-08 09:29:22 PDT - is it "Resolved" or does the "Invalid" indicate that it hasn't been resolved?

I too have no Collusion icon in the Add-on Bar, all that show there are 1Password 3.9.19 and DownloadHelper 4.9.15.  I also have avast! WebRep 8.0.4451  implemented and that doesn't show up in the Add-on Bar 

Could there be some conflict between one or more of these and Collusion, perhaps?  I'm not a techie so wouldn't really know where to look to prove or disprove this.

I have tried uninstalling Collusion and reinstalling it but to no avail.

I'm using, or attempting to use, Collusion 0.47 with Firefox 22.0 under MacOSX 10.6.8 Build 10K549, fully up to date according to Software Update, on a 27" i7 quad-core iMac with 16GB RAM.
(Reporter)

Comment 6

5 years ago
i called my initial bug request invalid because i determined that there was no bug, with firefox or collusion.  unchecking "always use private browsing" in firefox settings produced the desired/expected behaviour (collusion icon in add-on bar and "collusion graph" in tools menu).  

i'm currently using ff 22.0 and collusion 0.27.

(In reply to Norton Folgate from comment #5)
> I'm not sure if this question is still open as I don't understand the post
> by jemuse3 at 2013-07-08 09:29:22 PDT - is it "Resolved" or does the
> "Invalid" indicate that it hasn't been resolved?
> 
> I too have no Collusion icon in the Add-on Bar, all that show there are
> 1Password 3.9.19 and DownloadHelper 4.9.15.  I also have avast! WebRep
> 8.0.4451  implemented and that doesn't show up in the Add-on Bar 
> 
> Could there be some conflict between one or more of these and Collusion,
> perhaps?  I'm not a techie so wouldn't really know where to look to prove or
> disprove this.
> 
> I have tried uninstalling Collusion and reinstalling it but to no avail.
> 
> I'm using, or attempting to use, Collusion 0.47 with Firefox 22.0 under
> MacOSX 10.6.8 Build 10K549, fully up to date according to Software Update,
> on a 27" i7 quad-core iMac with 16GB RAM.

Comment 7

5 years ago
Thanks.

Sorry for veering slightly off topic, and please forgive the congenital techo-incompetence, but where is the Option for "always use private browsing"?  Or Settings for that matter.

I can find references and under that there is a Security tab where there are three Tracking options - I have "Do not tell sites anything about my tracking preferences", the others are "Tell sites that I do not want to be tracked" and "Tell sites that I want to be tracked".  There's also a "Never remember history" setting.

We both seem to be using Firefox 22.0, but I can't find the "private browsing" option which you mention!

I

Comment 8

5 years ago
Preferences, not references!  Sorry.
(Reporter)

Comment 9

5 years ago
ff > options > privacy tab

in the history block, set ...firefox will: use custom settings for history

a new set of options appear just below.
You need to log in before you can comment on or make changes to this bug.