Closed Bug 890372 Opened 8 years ago Closed 7 years ago

[webvtt] Dispatch onadd and onremove events in TextTrackList

Categories

(Core :: Audio/Video, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 893309

People

(Reporter: reyre, Assigned: reyre)

References

()

Details

Attachments

(1 file, 1 obsolete file)

These events are supposed to be fired when a Track has been removed or added respectively.
Assignee: nobody → rick.eyre
Status: NEW → ASSIGNED
We can't really test the "removetrack" event yet as there is no API in the track spec to do it.

I've opened a bug to possible change that. See https://bugzilla.mozilla.org/show_bug.cgi?id=891052
Attachment #772252 - Flags: review?(bzbarsky)
Duplicate of this bug: 882681
Blocks: 882703
Comment on attachment 772252 [details] [diff] [review]
v1: Dispatch onaddtrack and onremovetrack events

r=me, but do we need a separate bug about having these events be a TrackEvent?
Attachment #772252 - Flags: review?(bzbarsky) → review+
(In reply to Boris Zbarsky (:bz) from comment #3)
> r=me, but do we need a separate bug about having these events be a
> TrackEvent?

I'm not sure what that would entail or why we need that. Could you explain a little bit more or point me in a direction with more information?
We presumably need that because the spec says so.  See the spec link at 829958.

What it would entail is probaby not using DispatchTrustedEvent and instead creating your own Event objects of the right type and with the right data hanging off them, as well as creating a new subclass for TrackEvent instances.
(In reply to Boris Zbarsky (:bz) from comment #5)
> We presumably need that because the spec says so.  See the spec link at
> 829958.

Ah okay. I didn't notice it in the spec, but now that you point it out I do.

> What it would entail is probaby not using DispatchTrustedEvent and instead
> creating your own Event objects of the right type and with the right data
> hanging off them, as well as creating a new subclass for TrackEvent
> instances.

Would you rather I land this and open a new bug or for me to redo the patch with the TrackEvent stuff? I'm alright with just redoing the patch as it will need to be done in the future anyways.
I'm actually fine either way, depending no how soon we want the events.
Okay, let's land this now then and open a new bug so that we can have at least some initial support for it as it might be a few weeks at the worst when I am able to really concentrate on this again.

I've just added r=bz to the commit message.

Carrying forward r=bz

Try push: https://tbpl.mozilla.org/?tree=Try&rev=2936357be3e9
Attachment #772252 - Attachment is obsolete: true
Bug to change over to TrackEvents is now logged as bug 893309.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893309
You need to log in before you can comment on or make changes to this bug.