about:permissions page shows wrong cookie count

RESOLVED WONTFIX

Status

()

Firefox
Preferences
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Ben, Unassigned)

Tracking

22 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Browsed a page on www.facebook.com (not logged in). Facebook sets cookies.
Then opened a new tab and viewed about:permissions. Typed 'facebook' into the search box.


Actual results:

The page lists 'www.facebook.com' as the only entry in the left hand side. On the right hand panel, it reports that 0 cookies are set for this web site.


Expected results:

The cookie viewer (from firefox preferences) shows that three cookies are set for facebook.com. So the about:permissions page should report theses three cookies.

I suspect the problem is because of the conflicting domains. The cookies are for '.facebook.com' but the permissions page is showing 'www.facebook.com'. This is misleading. The 'facebook' search in the permissions page only listed 'www.facebook.com' so a user would conclude that no other facebook domains are relevant.

Since the .facebook.com cookies will be sent to www.facebook.com, they should be counted and listed for that domain on the permissions page.

Updated

5 years ago
Component: Untriaged → Preferences
about:permissions has been removed in bug 933917.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.