Closed Bug 890486 Opened 7 years ago Closed 7 years ago

[Email] Last folder name is not displayed properly in the value selector UL

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Details

(Whiteboard: [TD-58805], [LeoVB+])

Attachments

(3 files)

1. Title: Last folder name is not displayed properly in the value selector UL
2. Precondition: IMAP account configured on the device with more folders
3. Tester's Action:  1) Go to Inbox -> select any email 
                     2) Click on Move to Folder Icon 
                     3) Scroll down completely till the last folders
4. Detailed Symptom (ENG.) : Folder names at the last is not displayed in the value selector
5. Expected:  Email folder names should be displayed properly.
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train
8. Gaia Revision:  613e69ee0a009399130ad2cbb8b9d0462cd1fc70
9. Personal email id: psingapati@gmail.com
Value selector ul screen before changing the height
Value selector ul screen after changing the height
Attached file Pointer to PR
Reduced to Value selector UL height to scroll more on the dialog.

Please review.

Thanks
Attachment #771604 - Flags: review?(bugmail)
Comment on attachment 771604 [details]
Pointer to PR

Thanks for the fix!

Changing one arbitrary hard-coded constant to anotherhard-coded constant is usually the sign of a bigger problem that should be addressed.  However, I agree that making this small change is probably the right thing for our v1.1 devices at this time.  I've filed bug 890486 to be the bug where we fix this problem the right way.
Attachment #771604 - Flags: review?(bugmail) → review+
(In reply to Andrew Sutherland (:asuth) from comment #4)
> I've filed bug 890486 to be the bug where we fix this
> problem the right way.

Copy-and-paste error on my part.  I filed bug 890647 on properly fixing the error.

landed on gaia/master:
https://github.com/mozilla-b2g/gaia/pull/10808
https://github.com/mozilla-b2g/gaia/commit/b0d12a602607aade0925b0d440331b868f0bbecd

Nominating for leo+ so we can uplift this change since I assume it's going to go into the Leo v1.1 branch either way and I'd like to maximize consistency.
Status: NEW → RESOLVED
blocking-b2g: --- → leo?
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to Andrew Sutherland (:asuth) from comment #5)

> Nominating for leo+ so we can uplift this change since I assume it's going
> to go into the Leo v1.1 branch either way and I'd like to maximize
> consistency.

Hi, Andrew
Leo needs to uplift this patch to v1-train.
blocking-b2g: leo? → leo+
Uplifted b0d12a602607aade0925b0d440331b868f0bbecd to:
v1-train: 43020968f896a6eb321b09b5450dccee62e9e24c
Whiteboard: [TD-58805] → [TD-58805][LeoVB+]
Whiteboard: [TD-58805][LeoVB+] → [TD-58805], [LeoVB+]
v1.1.0hd: 43020968f896a6eb321b09b5450dccee62e9e24c
You need to log in before you can comment on or make changes to this bug.