clear cache button doesn't

VERIFIED WORKSFORME

Status

()

Core
Networking: Cache
VERIFIED WORKSFORME
17 years ago
7 years ago

People

(Reporter: chris hofmann, Assigned: dougt)

Tracking

({topembed})

Trunk
x86
Other
topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+)

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010627 Netscape6/6.1 

+ after successsive selection of clear cache nothing was cleared 
+ 
+ C:\sm-pr2\Users50\chofmann\NewCache>ls -lrt | WC
+    9906   89147  663649

bonk on clear cache...

+ C:\sm-pr2\Users50\chofmann\NewCache>ls -lrt | WC
+    9906   89147  663649

still 9906 entries in the cache.
bonk again.

+ C:\sm-pr2\Users50\chofmann\NewCache>ls -lrt | WC
+    9906   89147  663649

still 9906 entries in the cache.

browse some more...

C:\sm-pr2\Users50\chofmann\NewCache>ls -lrt | WC
   9945   89498  666262

more new files in the cache.

C:\sm-pr2\Users50\chofmann\NewCache>ls -lrt | tail
-rwxrwxrwa   1 0        0             49 Jul  3 07:56 F35610FAd01
-rwxrwxrwa   1 0        0            477 Jul  3 07:56 9850ED27d01
-rwxrwxrwa   1 0        0            370 Jul  3 07:56 8DD8D6A6d01
-rwxrwxrwa   1 0        0            368 Jul  3 07:56 11A4D753d01
-rwxrwxrwa   1 0        0            410 Jul  3 07:56 065725B1d01
-rwxrwxrwa   1 0        0             58 Jul  3 07:56 944F24E5d01
-rwxrwxrwa   1 0        0            113 Jul  3 07:56 80C81CFCd01
-rwxrwxrwa   1 0        0             90 Jul  3 07:56 7C50FD03d01
-rwxrwxrwa   1 0        0           7153 Jul  3 07:56 CC821272d01
-rwxrwxrwa   1 0        0          12929 Jul  3 07:58 42597ADCd01
(Reporter)

Comment 1

17 years ago
adding pdt+
Keywords: topembed
Whiteboard: PDT+

Comment 2

17 years ago
Adding Doug to cc list.  Gagan and Gordon both out.
Doug, this one got marked PDT+, can you find an owner?
(Assignee)

Comment 3

17 years ago
looking at the code, there is a check to see if there are any "active bindings" 
holding onto the cache entry.  If it is being used, the entry will be "doomed" 
which basically means the we flag as deleted.

Could you do this:

1. goto a couple of pages
2. record the "ls -lrt | WC" of the cache dir.
3. clink the clear disk cache button.
4. record the "ls -lrt | WC" of the cache dir.

Are you seeing any difference?

On windows 2k, I do see some difference:

Before ->     7      56     419
After  ->     5      38     282


The proper way to test this is to go to a few pages, blast out the cache, then 
revisit the pages and ensure that all data was transfer from the http server, 
and not retrieved from the cache.  I did this and am not seeing any cache 
entries returned from |FindEntry|.  

Marking invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Assignee)

Comment 4

17 years ago
I spoke to chris on the phone.  He has a NewCache directory with 9k+ files in
it.  When he clicks "clear disk cache" these files still exist.  It is like the
cache has forgotten these files (which is possibe since this profile has been
used for 6 weeks with daily builds AND the disk cache has changed considerably).

With a new profile and a small set of disk entries, clearing the disk cache does
work.  I will try to reproduce the large set of disk entries that chris has.  

Reopening bug based on this.  We need to understand how the cache can get into a
state where it forgets about cached files.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 5

17 years ago
put my tar'ed up newcache directory under /u/chofmann/nc.tar

also noticed in transfering it up there that I think its blown out
the default cache limit which is set on my profile at 50MB

26 Transfer complete.
ftp: 68270080 bytes sent
(Reporter)

Comment 6

17 years ago
so the next things to look at are:
-can some large amounts of browser busting lead to conditions where
  the cache limits can get blown out?
-if the blow out occurs, does a user forced cache cleanup get ingnored.
-is my cache problem reflective of a current problem or just
  the result of trying to use too many daily builds though
   cache developments over the past months.

first two problems are stoppers.

adding asa to the cc list.  he runs lots of browser buster sessions..
lets see if he has any evidence of blown out cache limits.

(Assignee)

Comment 7

17 years ago
taking
Assignee: gordon → dougt
Status: REOPENED → NEW
(Assignee)

Comment 8

17 years ago
related to 88146?
(Assignee)

Comment 9

17 years ago
chris, I can not reproduce this problem.  I started wtih a new profile, ran the
browser buster then ran the random page buster.  After about 2 1/2 hours I had a
bit over 50mb of stuff in my disk cache.  I then cleared cache and it went to
zero.  I then lowered my disk cache limit to 500k and try the same thing again
without any problem.  

Best guess at this point is that somehow during all of your testing and all the
changes in the disk cache, the cache files remaining in your cache directory
were ophaned.  

tever, can you try reproducing this?  
If you crash, then the disk cache index won't know about some of the files....

Do the files vanish when you quit the browser? And does about:cache show that
the disk cache is empty?
(Assignee)

Comment 11

17 years ago
no, no.
(Assignee)

Comment 12

17 years ago
I posted in the netlib newsgroup for feedback.

This works for me.  tever, have you been able to repro this?
Keywords: qawanted

Comment 13

17 years ago
Worksforme with 070204 mozilla win32 build on win2K, winXP and win98, 0070508
mozilla linux build on RedHat 6.2 and 0070508 mozilla mac build on OS 8.5 and 9.1

Tested: 
1 laoded about:cache to see greater than 100 memcache entries
2 cleared memcache in preferences window
3 loaded about:cache to see between 27 and 40 cached entries (All chrome:// URLs)

I'll ask around and see if anyone else is seeing the problem.
(Assignee)

Comment 14

17 years ago
asa, this is a disk cache bug.  Try with > 50 MB cache and > 9k of entries.
(Reporter)

Comment 15

17 years ago
yes somewhere along the line the number of cache entries that
the cache code knows about got disconnected with the actual 
number of cache entries left lying around.

about:cache shows....

Disk cache device
Number of entries: 175
Maximum storage size: 51200000 Bytes
Storage in use: 1413120 Bytes
Cache Directory: C:\SM-PR2\Users50\chofmann\NewCache
List Cache Entries 
and I still have over 9000 files in the NewCache directory shown above.
(Assignee)

Comment 16

17 years ago
we need someone to reproduce this either on the same build or between two 
builds (eg m0.9.1 and m0.9.2).

(Assignee)

Comment 17

17 years ago
okay.  well, if have not been able to repro this.  wrf
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 18

17 years ago
.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 19

17 years ago
wfm
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 20

17 years ago
wfm too.  ( 6/27 build )   Please re-open if you can find a way to reproduce it 
consistantly.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.