Closed Bug 89055 Opened 22 years ago Closed 22 years ago

Radio button does not uncheck when another radio button in the same group is selected.

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

VERIFIED INVALID

People

(Reporter: buzzcutbuddha, Assigned: rods)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

Given code like the following:

<input type="radio" value="1" name="foo">
	<br>
	<input type="radio" value="0" checked name="foo">
The bottom radio button loads checked, but if you click on the top button, it
does not remove the check from the bottom.

Reproducible: Sometimes
Steps to Reproduce:
1. Visit a webpage and find some radio buttons.
2. www.perlmonks.org has many a radio button, but Mozilla exhibits correct
behavior there.
3.  try to change the checkbox

Actual Results:  on mas.pipelineinteractive.com/untitled.cfm I got the error
results.

on Perlmonks, I did not get the error results.

Expected Results:  It should work per the W3C Standard.

It makes submissions on pages not work properly.  And it's new behavior that I
haven't seen before.
The reason you are not able to make changes in 
http://mas.pipelineinteractive.com/untitled.cfm is because the code is not 
within the form tags .

The source code for this page is :
==================================================================
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
<title>Untitled</title>
</head>
<body>
<!-- 	mas.pipelineinteractive.com<br> {ts '2001-07-03 13:04:50'}<br> -->
<input type="radio" value="1" name="foo">
<br>
<input type="radio" value="0" checked name="foo">
</body>
</html>
=====================================================
if you re-write the input tags within <form></form> tags, it'll work as desired.
marking this bug as invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → INVALID
invalid bug
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.