Closed Bug 890563 Opened 6 years ago Closed 6 years ago

DateTime Error when going to editwhines.cgi

Categories

(Bugzilla :: Whining, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 4.4

People

(Reporter: jingoro, Assigned: jingoro)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1. Login as a user
2. Click on Administration
3. Click on Whining



Actual results:

Got the error:

> Software error:
>
> Can't locate object method "now" via package "DateTime" at /home/bugzilla/bugzilla/editwhines.cgi line 387.



Expected results:

The normal "Set up whining" page.
Attached patch Fix for said bugSplinter Review
I cannot reproduce the error, but the fix makes sense.
Assignee: general → jingoro
Status: UNCONFIRMED → ASSIGNED
Component: Bugzilla-General → Whining
Ever confirmed: true
Target Milestone: --- → Bugzilla 4.4
Comment on attachment 771698 [details] [diff] [review]
Fix for said bug

r=LpSolit
Attachment #771698 - Flags: review+
Flags: approval4.4+
Flags: approval+
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified editwhines.cgi
Committed revision 8644.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified editwhines.cgi
Committed revision 8573.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 886853
You need to log in before you can comment on or make changes to this bug.