Closed Bug 890566 Opened 9 years ago Closed 8 years ago

Permissions should reset back to default

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 26

People

(Reporter: Dolske, Assigned: dao)

References

Details

Attachments

(1 file)

Not sure if this is a flaw in 885366, or existing permissions bug.

1) Visit some site (eg dolske.net)
2) Check doorhanger, no permissions listed
3) Page Info --> Media --> check Block Images from site
...
4) Open new tab for site
5) Check door hanger, permissions show "Load Images: Block"
6) Set to "Allow"
...
7) Open another new tab for site
8) Check door hanger, permissions show "Load Images: Allow"

The results in step 8 persists across a restart. Since allowing image loading is the default, I'd expect restoring "Allow" to make it stop showing up.
This is how permission persistence works by design. You can see this in the Page Info window by unchecking "use default", closing the window and re-opening it. "use default" will remain unchecked even though the state ("Allow") matches the default state. Also note that if you changed the default state to "Block", the selected option for that site would still be "Allow".
That said, bug 889835 makes SitePermissions.jsm know about the default states and we could clear permissions when the state selected in the identity popup matches the default state. We just need to decide whether we want that. See also bug 885366 comment 8.
Keywords: uiwanted
OS: Mac OS X → All
Hardware: x86 → All
Flags: needinfo?(jboriss)
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #777299 - Flags: ui-review?(jboriss)
Attachment #777299 - Flags: review?(dolske)
Attachment #777299 - Flags: review?(dolske) → review+
Boriss: last call!
Attachment #777299 - Flags: ui-review?(jboriss)
https://hg.mozilla.org/mozilla-central/rev/d61263a013b3
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.