Too many add-ons related to findbar are broken due to landing Bug 537013

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({addon-compat})

25 Branch
x86_64
All
addon-compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f29cb83f66bd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130705 Firefox/25.0 ID:20130705175744

https://addons.mozilla.org/en-US/firefox/addon/findbar-tweak/?src=search
  --- no extra item in the findbar
https://addons.mozilla.org/en-US/firefox/addon/enhanced-findbar/?src=search
  --- findbar disappears when findnext, prev repeatedly performed
https://addons.mozilla.org/en-US/firefox/addon/findbar-favorites/?src=search
  --- no favorites item in the findbar
https://addons.mozilla.org/en-US/firefox/addon/find-toolbar-tweaks/?src=search
  --- no findbar opened with ctrl+f

Many add-ons related to findbar will stop working
Are there specific compatibility concerns or things that should be done to improve addon compat?

If not, I don't see much actionable here. Firefox doesn't guarantee 100% compatibility from release-to-release, nor should we hold back improvements simply due to some add-ons not working improperly. If anything, this becomes an addon-outreach issue: "things changed, this is how it works now, please fix your addon appropriately".
(Reporter)

Comment 2

5 years ago
I think that
some custom event should be provided such as
when added findbar to the tab
or ready to use findbar
(Reporter)

Comment 3

5 years ago
And I think personally,
pros
Actually, I do not need the feature of Bug 537013.
If some one need the feature, alternative add-ons are already available without such breakage.
https://addons.mozilla.org/en-US/firefox/addon/findbar-autohide/?src=search
https://addons.mozilla.org/en-US/firefox/addon/hide-findbar/?src=search

cons
Many add-ons related to findbar will stop working
(Reporter)

Comment 4

5 years ago
The implementation of the Bug 537013 is very poor than the above alternatives .
(In reply to Alice0775 White from comment #4)
> The implementation of the Bug 537013 is very poor than the above
> alternatives .

What bug 537013 did is smarter than just hiding the find bar when switching tabs. For instance, it allows you to look for different things in different tabs without typing in the find bar in one tab throwing away another tab's find bar state. Earlier patches in bug 537013 tried to support this by taking snapshots of the global find bar's state and storing them for each tab, but that's a lot messier than having one find bar per tab.

(In reply to Alice0775 White from comment #2)
> I think that
> some custom event should be provided such as
> when added findbar to the tab
> or ready to use findbar

It's not clear to me how this would fix broken add-ons or that this solves a common problem that all those add-ons would face in order to be updated.
Closing as filed, per comment 1. If there are specific things that would help add-on authors work in the new way of things, please file bugs on that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Duplicate of this bug: 891152
You need to log in before you can comment on or make changes to this bug.