[csb] UTF-8 BOM after MPL2 license header in newAddon.dtd: Unparsed content " "

RESOLVED FIXED

Status

Mozilla Localizations
csb / Kashubian
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: flod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

csb is one of the locales working on MPL2 relicensing (bug 792719).

Aurora (with license headers)
compare-locales
https://l10n.mozilla.org/dashboard/compare?run=325215

file
http://hg.mozilla.org/releases/l10n/mozilla-aurora/csb/file/3243d5ad350f/toolkit/chrome/mozapps/extensions/newaddon.dtd

This is the error (to be really honest I don't understand those numbers)
Unparsed content " " at 211-214

Beta (without license headers)
compare-locales
https://l10n.mozilla.org/dashboard/compare?run=322335

file
http://hg.mozilla.org/releases/l10n/mozilla-beta/csb/file/605d1b2228a1/toolkit/chrome/mozapps/extensions/newaddon.dtd

No errors.

If I remove the license header on the Aurora's file compare-locales completes without errors.

Comment 1

5 years ago
That's a known regression from mpl2, when the old file has a utf-8 BOM, that moves into the middle of the file, and is illegal.

Also, three bytes.

We have seen that a few times with search plugins.
Component: Infrastructure → csb / Kashubian
Summary: [compare-locales] MPL2 license header in newAddon.dtd triggers error: Unparsed content " " → [csb] UTF-8 BOM after MPL2 license header in newAddon.dtd: Unparsed content " "
Just reached the same conclusion by making a diff between this file in it and csb.

I'm going to remove the BOM from the file to fix the problem. Should we leave this bug open for compare-locales?
(In reply to Axel Hecht [:Pike] from comment #1)
> We have seen that a few times with search plugins.

Argh, thanks for the heads-up.

grep -rl $'\xEF\xBB\xBF' .
./browser/searchplugins/merlin-pl.xml
./browser/searchplugins/pwn-pl.xml
./browser/searchplugins/allegro-pl.xml
./browser/searchplugins/fbc-pl.xml
./browser/searchplugins/wikipedia-csb.xml
./browser/searchplugins/wp-pl.xml

Fixed .dtd file
http://hg.mozilla.org/releases/l10n/mozilla-aurora/csb/rev/11181b2e01ae

Fixed searchplugins
http://hg.mozilla.org/releases/l10n/mozilla-aurora/csb/rev/6b86ef5dee15

Comment 4

5 years ago
This isn't a bug in compare-locales, the BOF inside the file should create parsing errors, I think.
Not sure either. It seems to be deprecated in the middle of a file
http://en.wikipedia.org/wiki/Zero-width_non-breaking_space
http://www.unicode.org/faq/utf_bom.html#bom6

Anyway, let's close this bug as it's been fixed on the locale's side.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.