Can't see current time when alarm ring with screen locked or snoozed timer

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Clock
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: mathieu, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected)

Details

(Reporter)

Description

5 years ago
steps to reproduce : 

1. setup an alarm in the future
2. lock screen
3. wait for alarm to ring
4. snooze
5. wait for alarm to ring again



the alarm screen display the original alarm time but I can't see the current time (especially annoying after hitting snooze one or more time)
it's ok if the device is not locked because the current time is shown in the status bar. but when locked the current time is not displayed on the status bar probably because it's displayed on the lock screen. unfortunately, when the alarm ring the lock screen is not visible anymore

related to #804702 and #846344
Hi mathieu,

Thanks for your point out. We have confirmed the behavior via bug 804702. But as a user, I agree with your opinion. They might want to know what time it is during alarm goes off. NeedInfo our UX team.
Flags: needinfo?(firefoxos-ux-bugzilla)
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 2

5 years ago
Removing needinfo? since I *believe* this will be solved by the extensive changes to clock and alarms for 1.2. The DRAFT specs (NOT READY for implementation) are posted in Box here. Implementation will be handled in future sprints by the Productivity team:
https://mozilla.box.com/s/98mrvl6u7v8e1cshqn99
Flags: needinfo?(firefoxos-ux-bugzilla)
This is a really annoying behavior actually, which caused me to stand up later today, because after the 3rd snoozed alarm I was still thinking it's still around the alarm time but it was already 30 minutes later.
Status: UNCONFIRMED → NEW
status-b2g18: --- → affected
Ever confirmed: true
Summary: Can't see current time when alarm ring with screen locked → Can't see current time when alarm ring with screen locked or snoozed timer
Verified on v1.3 that this is no longer a problem. The snoozed alarm screen now shows the current time rather than the time of the original alarm.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.