Editing Start/End in Image event editor doesn't update track event

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jon, Assigned: mjschranz)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1) Add an image event anywhere
2) Attempt to change start/end to anything else
3) Notice that it doesn't change
(Assignee)

Updated

5 years ago
Assignee: nobody → schranz.m
These steps didn't produce a bug for me.

Are there other things I could be missing?

Any error logs?
(Assignee)

Comment 2

5 years ago
Same. I can't reproduce this. You were there Jon, can you give us more specific details?
Flags: needinfo?(jon)
(Reporter)

Comment 3

5 years ago
Sorry should've been more specific, attempt to change the start/end times in the editor, not on the tray.
Flags: needinfo?(jon)
(Assignee)

Comment 4

5 years ago
I did in the editor. Was changing the times accordingly. I don't see it locally in FF/Chrome or on production.

Either I'm missing something, the STR is missing something or this isn't a bug.
Flags: needinfo?(jon)
(Reporter)

Comment 5

5 years ago
This is most definitely a bug: https://dl.dropboxusercontent.com/u/4403845/image-editor-bug.mov
Flags: needinfo?(jon)
(Assignee)

Comment 6

5 years ago
Created attachment 772229 [details] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/100

So our code to "mimic" input type=number was causing this to break these inputs. I don't think I can remove that code since it's still needed for other inputs so I'll just change these to text.
Attachment #772229 - Flags: review?(jon)
(Reporter)

Updated

5 years ago
Attachment #772229 - Flags: review?(jon) → review+

Comment 7

5 years ago
Commit pushed to master at https://github.com/mozilla/popcorn.webmaker.org

https://github.com/mozilla/popcorn.webmaker.org/commit/5df4417b1460afba1bad5f77cbec43d6f2b4d730
Fix Bug 890651 - Work around for Firefox not supporting input type=number was breaking our custom timestamp start/end inputs

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.