Users aren't notified if a username already exists

RESOLVED FIXED

Status

Webmaker
Login
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jbuck, Assigned: mjschranz)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1) Sign in with an email address that does not have a webmaker account associated with it
2) Attempt to claim a domain that already exists
3) No feedback that "this domain already exists"
(Reporter)

Comment 1

5 years ago
Assigning to Matt, because I think this might be a regression from the loginapi changes.
Assignee: nobody → schranz.m
Status: NEW → ASSIGNED
(Assignee)

Comment 2

5 years ago
Causing commit https://github.com/mozilla/login.webmaker.org/commit/81142e28d621c07e3b4a3416ae2f041dd861e5ba

This added error handling there, but in this case it doesn't check the kind of error.
(Assignee)

Comment 3

5 years ago
Created attachment 771798 [details] [review]
https://github.com/mozilla/login.webmaker.org/pull/125

Really basic UI but, it's better than the nothing that was there before.
Attachment #771798 - Flags: review?(pomax)

Comment 4

5 years ago
Comment on attachment 771798 [details] [review]
https://github.com/mozilla/login.webmaker.org/pull/125

the error message needs a tweak, but that err_msg var really bugs me, since we're touching pretty much all the code that uses it here, let's rename it and make it obvious what it's used for.
Attachment #771798 - Flags: review?(pomax) → review-
(Assignee)

Updated

5 years ago
Attachment #771798 - Flags: review- → review?(pomax)

Comment 5

5 years ago
Comment on attachment 771798 [details] [review]
https://github.com/mozilla/login.webmaker.org/pull/125

yeah, this works quite well for me.
Attachment #771798 - Flags: review?(pomax) → review+

Comment 6

5 years ago
Commit pushed to master at https://github.com/mozilla/login.webmaker.org

https://github.com/mozilla/login.webmaker.org/commit/4d682082525a5a43b796633e28367865bc84f922
Fix Bug 890656 - No notification if username was taken when claiming domain in userbar

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.