Duck typing for Error instances fails when do_throw is passed a string

RESOLVED DUPLICATE of bug 890555

Status

Testing
XPCShell Harness
RESOLVED DUPLICATE of bug 890555
5 years ago
5 years ago

People

(Reporter: jdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

This can lead to confusing stacks like this:

> 0:04.00 parent: TEST-UNEXPECTED-FAIL | ../unit/head_crashreporter.js | Unexpected exception TypeError: invalid 'in' operand error, see following stack:
> 0:04.00 do_throw@/home/mihnea/localCode/Mozilla/mc/testing/xpcshell/head.js:482
> 0:04.00 handleMinidump@../unit/head_crashreporter.js:85
> 0:04.00 do_content_crash/handleCrash@../unit/head_crashreporter.js:131
> 0:04.00 do_execute_soon/<.run@/home/mihnea/localCode/Mozilla/mc/testing/xpcshell/head.js:444

wherein the actual error is totally obscured.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890555
You need to log in before you can comment on or make changes to this bug.