Closed Bug 890708 Opened 7 years ago Closed 7 years ago

LoginManager opens sqlite db on main thread causing janks

Categories

(Toolkit :: Password Manager, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 853549

People

(Reporter: mayhemer, Unassigned)

Details

(Keywords: perf)

0 anonymous() ["file:///C:/Mozilla/src/gum/_obj-browser-debug/dist/bin/components/storage-mozStorage.js":1282]
    this = [object Object]
1 anonymous() ["file:///C:/Mozilla/src/gum/_obj-browser-debug/dist/bin/components/storage-mozStorage.js":209]
    this = [object Object]
2 anonymous() ["file:///C:/Mozilla/src/gum/_obj-browser-debug/dist/bin/components/nsLoginManager.js":98]
    this = [object Object]
3 anonymous() ["file:///C:/Mozilla/src/gum/_obj-browser-debug/dist/bin/components/nsLoginManager.js":353]
    this = [object Object]
4 anonymous() ["resource://gre/modules/LoginManagerContent.jsm":500]
    this = [object Object]
5 anonymous() ["resource://gre/modules/LoginManagerContent.jsm":105]
    this = [object Object]
6 anonymous() ["chrome://browser/content/content.js":38]
    this = [object ContentFrameMessageManager @ 0x86140a0 (native @ 0x8ac1b30)]

content.js:38:
addEventListener("DOMContentLoaded", function(event) {
>  LoginManagerContent.onContentLoaded(event);
});
known problem, you can check bug 699820 for a list of known offenders
Depends on: 853549
Status: NEW → RESOLVED
Closed: 7 years ago
No longer depends on: 853549
Resolution: --- → DUPLICATE
Duplicate of bug: 853549
You need to log in before you can comment on or make changes to this bug.