quick start only works the 1st time I open mozilla

VERIFIED INVALID

Status

SeaMonkey
UI Design
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: Clark, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628
BuildID:    200162815

When I 1st start my machine and start mozilla, it goes straight to the profile
manager without seeing the mozilla intro screen (the fire breathing lizard).  If
I close it and re-open it, sometimes I get a new browser window almost instantly
(faster than IE 5.5!!!) :-)  Other times I get the fire breathing lizard and the
profile manager again. 

Reproducible: Sometimes
Steps to Reproduce:
1.start the computer, open mozilla with quick start (this part works great!)
2. close mozilla
3.open it again.
Reporter: 
Do you close Mozilla with File/exit (CTRL+Q) ?
File/exit = mozilla will closed completly (with the mozilla turbo task)
or do you see this when you close mozilla with the "x" ?
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
->vishy
Assignee: pchen → vishy
QA Contact: sairuh → paw
--> conrad
Assignee: vishy → ccarlen
(Assignee)

Comment 4

17 years ago
WFM on a trunk build which was pulled after bug 89060 was fixed. Are people
seeing this on the branch?
Date: Tue, 3 Jul 2001 12:18:54 -0700 (PDT)
From: CM K <cmk_78212@yahoo.com>
To: Matti@epost.de

I closed using the "x"  I would like to have the quick
start feature work  the entire time I have the
computer running no matter how I close the program

Comment 6

17 years ago
on win2k, with multiple profiles: 

1) start '.\mozilla -turbo' :     program starts but shows no UI
2) double-click mozilla program : profilemanager comes up, choose profile,
                                  browser starts at home page of selected 
                                  profile
3) click 'X' window control :     browser window disappears, but program 
                                  remains alive
4) double-click mozilla program : browser starts at home page of selected       
                                  profile 
5) repeat 3 and 4 for however many times you want
6) do 'File->Exit' in last browser window : browser window disappears and 
                                            program completely shuts down
7) double-click mozilla program : splash screen comes up, then profile manager,
                                  select profile, browser starts at home page 
                                  of selected profile
8) click 'X' close control : browser window closes and program completely 
                             shuts down
9) double-click mozilla program : splash screen comes up, then profile manager,
                                  select profile, browser starts at home page 
                                  of selected profile
10) do 'File->Exit'        : browser window closes and program completely 
                             shuts down

Okay, so that is how this is supposed to work, right Conrad? This is not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Assignee)

Comment 7

17 years ago
That sounds exactly right to me.

I'm not sure how this feature is going to be explained in the documentation. It
needs to be made very clear what turbo mode is doing (keeping the app alive with
no windows). Also, the difference between closing the last window and choosing
File/Exit needs to be explained.

If not, I bet many others will expect this:

"I would like to have the quick
start feature work  the entire time I have the
computer running no matter how I close the program"
 

Comment 8

17 years ago
Yes, I think explaining this in the documentation clearly is critical (and 
it may be difficult for some people to "get" the idea, even then). It also 
might be an idea to place a shortcut in the start menu folder for the browser
that would be called "start turbo" or some such. This would allow people to 
have easy access to restart the 'stay-resident' mode if they have done 
'File->Exit'. [But, the ability to do File->Exit and have the application
completely exit is necessary as without it, there is no way do a clean and 
complete restart of the program (leaving behind any weird state that a user
may have worked themselves into)].

Todd : are we considering such a shortcut? Should we? Also, who owns the 
documentation/spec for this feature and exactly what it should do from an
end-user's perspective.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

17 years ago
> It also might be an idea to place a shortcut in the start menu folder for
> the browser that would be called "start turbo" or some such. This would allow
> people to have easy access to restart the 'stay-resident' mode if they have
> done 'File->Exit'.

I agree. It was discussed (I think favorably) a while back. I'm not sure if the
idea was dropped or if it's something that is intended but not there yet.

Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.