ReferenceError: __flash__argumentsToXML is not defined - Picture Upload Button (Everytrail.com) does not lead to the expected File Open Dialog Box

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: tinl, Unassigned)

Tracking

22 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1. Login to my account on www.everytrail.com
2. Navigate to an uploaded trip
3. ``Edit pictures and videos´´ refer to <http://www.everytrail.com/edit_pictures.php?trip_id=aTripId>, in order to populate the trip with pictures, that could be uploaded an positioned


Actual results:

Nothing


Expected results:

File Open Dialog Box should appear

- Firefox 22.0
- Windows XP Professional
Thanks for reporting this!
Have you ever had this problem with previous Firefox versions?
Does the web console show you an error message? (Tools > Web Developer > Web Console)
(Reporter)

Comment 2

5 years ago
1. do not remember if this ever did occur with former versions
2. I did mention the steps to reproduce.
3. ... but:
after opening the Web Console and even closing it afterwards: everthing work as expected! Restarting firefox without opening the Web Console results in the behavior mentioned in my inital bug report dated 2013-07-07 12:23:29 PDT.
4. opening the Web Console shows:
[23:24:47.542] ReferenceError: __flash__argumentsToXML is not defined @ http://www.everytrail.com/js/common/mootools-1.2.5-core-jm.js:115

NB: the second time, it does not work even if Web Console is opened
Summary: Picture Upload Button (Everytrail.com) does not lead to the expected File Open Dialog Box → ReferenceError: __flash__argumentsToXML is not defined - Picture Upload Button (Everytrail.com) does not lead to the expected File Open Dialog Box
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 3

5 years ago
Unfortunately due to the complexity of Flash and Firefox, it's going to be pretty hard to debug this with a large testcase like this. However, it would help if you can run some tests and help us figure out when this broke in our nightly builds. That will help us see which changes might have caused an issue (or if this is perhaps an issue caused by a Flash upgrade instead of a Firefox upgrade):

http://mozilla.github.io/mozregression/ is a tool which can help find the regression range.
Flags: needinfo?(tinl)
(Reporter)

Comment 4

5 years ago
1. The bug is for me not reproducable anymore. I have Shockwave Flash 11.8.800.94 installed now. What I had before is not known.

2. The http://mozilla.github.io/mozregression/ did not report any bad nightly affected. See below.

3. http://mozilla.github.io/mozregression/ needs to be improved: start-l10n.bat does not work with path names with blanks!

4. The inconveniences might have been initiated by:
   - Shockwave Flash
   - other installed plug-ins/add-ons

Output from mozregression:
$ mozregression
No 'good' date specified, using 2009-01-01
Downloading nightly from 2011-05-03
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2012-07-02
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-01-31
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-05-17
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-07-09
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-08-05
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-08-18
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-08-25
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-08-28
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-08-30
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good
Downloading nightly from 2013-08-31
Installing nightly
Starting nightly
Was this nightly good, bad, or broken? (type 'good', 'bad', 'skip', 'retry', or
'exit' and press Enter): good


Last good nightly: 2013-08-31
First bad nightly: 2013-09-01

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2013-08-31&enddate=2
013-09-01

do you want to bisect further by fetching the repository and building? (y or n)
n
Closing for now, let us know if you can consistently reproduce this or have any further information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

5 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Updated

5 years ago
Flags: needinfo?(tinl)
Resolution: INCOMPLETE → WONTFIX
You need to log in before you can comment on or make changes to this bug.