Video player opens behind the YouTube overlay when launched from an app

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: MattN, Unassigned)

Tracking

({b2g-testdriver, unagi})

Firefox Tracking Flags

(Not tracked)

Details

STR:
1) Load the Facebook everything.me app
2) Find a YouTube video a friend shared and click on the play icon in the Facebook timeline
3) An YouTube overlay appears with an X in the upper left.
4) Click the |> (play) icon within the YouTube webpage to start playing the video

Expected result:
The system media player appears on top of everything and plays the video

Actual result:
After a delay for buffering, I can hear the audio playing but I see no video because the YouTube overlay is above the system video player. Tapping the X in the top-left of the YouTube overlay shows me the media player with the video playing.

Reproducible: always

Until a user learns that the video is playing behind the overlay, this is very frustrating and seems totally broken.  After figuring out what's going on it's still a really poor UX since you have to close the YouTube overlay to see the video which means you can't comment/share/save/etc. the video on YouTube after without re-opening the overlay from the original app (if possible).

Build: unagi/1.1.0/beta
20130701070213

Comment 1

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.