build error in webrtc/signaling when using vs2013

RESOLVED DUPLICATE of bug 890211

Status

RESOLVED DUPLICATE of bug 890211
5 years ago
9 months ago

People

(Reporter: c, Unassigned)

Tracking

Trunk
x86
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130706191431

Steps to reproduce:

using vs2013 to build firefox, I run into errors in media/webrtc/signaling.

MediaPipeline.cpp
d:\develop\mozilla\central\obj-12\media\webrtc\signaling\signaling_ecc\../../../
../dist/include/mozilla-config.h(128) : warning C4005: “WINVER”: 宏重定义
        命令行参数: 参见前面的“WINVER”定义
d:\develop\mozilla\central\obj-12\media\webrtc\signaling\signaling_ecc\../../../
../dist/include/mozilla-config.h(135) : warning C4005: “_WIN32_WINNT”: 宏重定
义
        命令行参数: 参见前面的“_WIN32_WINNT”定义
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\inttypes.h(237) :
 error C2084: 函数“__int64 abs(__int64) throw()”已有主体
        C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\stdlib.h(
501) : 参见“abs”的前一个定义
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\inttypes.h(242) :
 error C2556: “imaxdiv_t div(intmax_t,intmax_t)”: 重载函数与“lldiv_t div(__in
t64,__int64) throw()”只是在返回类型上不同
        C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\stdlib.h(
509) : 参见“div”的声明
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\inttypes.h(242) :
 error C2371: “div”: 重定义;不同的基类型
        C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\INCLUDE\stdlib.h(
509) : 参见“div”的声明

the inttypes.h is included by http://mxr.mozilla.org/mozilla-central/source/netwerk/srtp/src/crypto/﷒0﷓

after I remove this line, the build can pass.
(Reporter)

Updated

5 years ago
Hardware: x86_64 → x86
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890211

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.