address bar search now using search engine

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: neil, Unassigned)

Tracking

23 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130703181823

Steps to reproduce:

Typed an entry in the address bar


Actual results:

it used whatever I have listed in the search engine bar. I am on beta 23.


Expected results:

used my built in search engine. Is this related to 203959?

If so, this is hideous and horrible. What is the point in giving a separate search engine bar for searching different stuff and the ability to type a search into the address bar when they now do the same thing?

it is making typing into the awesome bar not awesome, but aweful.

Please put this back, I'm moving to Chrome if not. It is detestible and serves no purpose to reduce the awesome bar to being a child of the search engine.
(Reporter)

Comment 1

5 years ago
As a typical use case scenario. If I want to search my history or use Google I type into the address bar and press enter; if I want to search wikipedia I type into my search engine (which I have defaulted to wikipedia) and press enter. Simple.

Now you cannot do it.

Updated

5 years ago
Blocks: 738818
Component: Untriaged → Search

Comment 2

5 years ago
The search bar was never intended to give you a permanent second search engine.
Also, keyword search doesn't work in all cases, see bug 738818 comment 142.

This change was intentional, to be less confusing for the user.

2 possible solutions for you:
- Bug 889113
- keyword bookmarks, see bug 738818 comment 143

I strongly recommend that you create keyword bookmarks for yourself. I do that with a lot of services, and it's one of the most practical Firefox features.

Comment 3

5 years ago
Recommending WONTFIX
...taking Ben's suggestion; he provided excellent alternatives.

Neil, thanks for reporting the bug. I hope you understand now why we made this change.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

5 years ago
ok, fair enough. How many average users do you think will go to the bother of using keywords? none, I expect. How can you say entering a string into the address bar which now returns (for example) only ebay searches is a step forward?

Sorry for the negative feedback, but the greatest thing about Firefox was the ability to return search results from everywhere, which is why google copied it with Chrome and are still using this search system.

This to me is a completely backward step (a bit like all the fantastic functionality you've added to the tab group system yet you let it all down by not allowing someone to save their pages or unload them for future use making it a pointless option).
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX

Comment 6

5 years ago
Hi, I use the search bar to translate fr->en and en->fr with wordreference. Now I can't do that, I know I have the keywords but I can't get used to use them, and I'm a power user so I don't even imagine what a normal user would do.

1. In my opinion you guys should add an icon of the search engine used somewhere, changeable by clicking on it or by entering the keywords. Right now entering a search engine's keyword doesn't do anything right away so I never know if I memorized it well or if it's not gonna work.

2. But what would be really good is a way to translate things really fast in the browser. Chrome ask if you want to translate a page, I love that although I seldom use it. What I use is "context search" that allows me to select something, right click and translate directly through wordreference.com

Comment 8

5 years ago
> translate fr->en and en->fr with wordreference. Now I can't do that,

Yes, you can. I said how here in comment 2: keyword bookmarks, see bug 738818 comment 143
I do exactly that all the time, for the very same purpose of translation. It keyword bookmarks work much better than the search bar, because I can have several different dictionaries, and for several languages.

Comment 9

5 years ago
> keyword bookmarks, see bug 738818 comment 143

A quick tip for all those power users here who want to use an additional search engine (this actually allows you to use an arbitrary number): Use bookmark keywords.
1. Go to e.g. http://www.youtube.com
2. In a search box, make a right click
3. Click "Add a keyword for this search..."
4. Enter as name e.g. "YouTube search (keyword youtube)" and keyword "yt", and Save
5. In the urlbar, enter "yt Rick Astley"
6. You have been rickrolled.

I do this for a lot of stuff, including wikipedia (in different languages), youtube, word dictionaries etc.

Comment 10

5 years ago
> select something, right click and translate directly

This is provided by https://addons.mozilla.org/firefox/addon/keyword-bookmarks/ that Aleksej listed in comment 7

Comment 11

5 years ago
Seems like you 3 haven't read what I wrote.

@Alekseyj : you gave me plugins that do exactly what "context search" does, and I already use it.

@BenB : I wrote about keyword bookmarks as well, and I said they weren't implemented for the normal user, and I proposed this : 

1. combine search bar & address bar to avoid confusion

2. add an icon in the address bar to tell the user which search engine he's using if he doesn't enter an url

3.1. if you start by writing "yt " for example, it will change the icon of the search engine and tell you that you're now searching in youtube

3.2 to push users to use this feature, write "yt " at the start of the address bar if they manually change the search engine through the icon.

What do you think of that?

I'll now have to change my habits by using those keywords bookmark but I'm sure we can do something for normal users.

Comment 12

5 years ago
I've got a stable release version. I type into the address bar and it searches for me at my defined home page (google.co.uk). If I type into the search bar I get whatever I choose (wikipedia, ebay, etc).

In this new version I type into the address bar and I get ebay, or wikipedia.

How can you not see that this (regardless of fancy shortcuts, etc) is just ****?

Honestly, I'm only here for noscript and adblock, but when this beta goes to stable I'm off to Chrome.
Duplicate of this bug: 897788
Duplicate of this bug: 902161

Comment 15

5 years ago
While the URL bar was never intended to be used as a secondary search bar, that is how the user community is using it.  That's the behavior of the URL bar for a very long time. Have a single URL bar that can search history/tabs and then google is great.  Leaving the 'search' bar for more esoteric searches or secondary engines.

There's no need to have both bars using the same settings.  This behavior should be reverted back to the version 22 behavior.
You need to log in before you can comment on or make changes to this bug.