Crash when creating object url in subworker

RESOLVED FIXED in Firefox 24

Status

()

Core
DOM: Workers
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: pieter-jan.speelmans, Assigned: baku)

Tracking

({crash})

22 Branch
mozilla25
x86
Windows 7
crash
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox22 affected, firefox23 affected, firefox24 fixed, firefox25 fixed)

Details

(crash signature)

Attachments

(1 attachment, 1 obsolete attachment)

5.35 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Create a web worker (worker1) which spawns a new web worker (worker2) and sends it a message.
Let worker2 create a objectURL.

I made you a fiddle with a "Crash firefox"-button: http://jsfiddle.net/HmNLP/


Actual results:

Firefox crashes


Expected results:

Firefox shouldn't crash... and make my objectURL

Comment 1

5 years ago
This WFM on Nightly. Can you please post one/more crash IDs? You can find them by going to about:crashes in your browser. Thank you! :-)
Flags: needinfo?(pieter-jan.speelmans)
(Reporter)

Comment 4

5 years ago
This?
https://crash-stats.mozilla.com/report/index/d04cfef1-da40-495a-998c-8154a2130708
Flags: needinfo?(pieter-jan.speelmans)

Updated

5 years ago
Severity: normal → critical
Crash Signature: [@ CreateURLRunnable::MainThreadRun() ]
Component: Untriaged → DOM: Workers
Keywords: crash
Product: Firefox → Core
Hardware: x86_64 → x86

Comment 6

5 years ago
(In reply to David Rajchenbach Teller [:Yoric] from comment #5)
> Definitely looks like bug 883784.

Yes, getting a nightly that doesn't have that at the minute. Maybe we want to uplift that if the crash is web-triggerable? It's already on Aurora now, I can't judge whether that's a patch that we could safely land on beta.

Comment 7

5 years ago
Confirmed. Yoric, wanna see if we can land that on beta?

(I don't actually know what to do with this bug now... technically it's FIXED, I guess? Confirming for now... :-\ )
Blocks: 883784
Status: UNCONFIRMED → NEW
status-firefox22: --- → affected
status-firefox23: --- → affected
status-firefox24: --- → fixed
status-firefox25: --- → fixed
Ever confirmed: true
We should see that with baku.
Flags: needinfo?(amarchesini)
(Assignee)

Updated

5 years ago
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
(Assignee)

Comment 9

5 years ago
Created attachment 772111 [details] [diff] [review]
patch
Attachment #772111 - Flags: review?(bent.mozilla)
(Assignee)

Comment 10

5 years ago
bug 883784 is needed but it's not enough. Here a patch to fix this issue.
Comment on attachment 772111 [details] [diff] [review]
patch

Review of attachment 772111 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #772111 - Flags: review?(bent.mozilla) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/f48599a7efa2

Friendly reminder - commit messages should be summarizing what the patch is doing, not just blindly restating the bug summary.
Keywords: checkin-needed
(Assignee)

Comment 14

5 years ago
https://tbpl.mozilla.org/?tree=Try&rev=8970065a78fe

I don't see any problem in try... Could it be something else?
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/projects/birch/rev/d8a89848224b
Flags: in-testsuite+
Keywords: checkin-needed
(In reply to Andrea Marchesini (:baku) from comment #14)
> https://tbpl.mozilla.org/?tree=Try&rev=8970065a78fe
> 
> I don't see any problem in try... Could it be something else?

It's there...B2G mochitest-9. And shockingly, it broke on birch too. Backed out.
https://hg.mozilla.org/projects/birch/rev/befbe3aa46fc
https://hg.mozilla.org/mozilla-central/rev/b96c56413b5e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.