Please make last crash ID easily retrievable on non-rooted phone

RESOLVED DUPLICATE of bug 908896

Status

RESOLVED DUPLICATE of bug 908896
5 years ago
5 years ago

People

(Reporter: akeybl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Please make last crash ID easily retrievable on non-rooted phone. This will make our stability checks much easier (for both Mozilla QA and partners) prior to release.

Fabrice, would you happen to have a good suggestion of how to accomplish this? If you don't have time to look at this in the 1.2 timeframe, let us know. Laura said she may be able to find somebody to help.
Flags: needinfo?(fabrice)
I we want that to be available on non-rooted device we can use a setting, and display the crash id in the settings app (probably in the "More Information" panel). Would this be ok for you?
Flags: needinfo?(fabrice)

Comment 2

5 years ago
This is basically a variant of bug 791380, BTW. If we put it in Settings, we should surely hide it in "More Information", maybe even the "developer" section underneath. And I think it would be great if there would be a "share" action on it so we could e.g. email the crash ID or its URL to a machine with a bigger screen (and where one can copy/paste it into a bug report as well, if needed).
:fabrice, is the effort too big to be considered a wontfix for 1.2 here ? Or any other low risk alternatives here still hit it.This will be useful from stability perspective .
Flags: needinfo?(fabrice)

Comment 4

5 years ago
Because bug 791380 is fixed, this is now possible via a privileged app (and fabrice provided a super-dumb version of that app in the bug). The rest of this appears to be a dup of bug 908896 which was filed as a followup of that bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(fabrice)
Resolution: --- → DUPLICATE
Duplicate of bug: 908896

Updated

5 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.