Closed Bug 891014 Opened 7 years ago Closed 7 years ago

[Music] [User story] Display an icon in the status bar while music is still playing

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

RESOLVED FIXED
blocking-b2g koi+

People

(Reporter: skasetti, Assigned: dkuo)

References

Details

(Whiteboard: [UCID:Media12, FT:Media, KOI:P1] feature=story c=music )

Attachments

(5 files, 2 obsolete files)

User Story:
As a user, when I exit the music application while the music is still playing I want to see an icon on the status bar indicating that music is still being played while the home screen is still unlocked

Acceptance Criteria:
1. The user exits the music application and keeps the screen in unlocked state. He/she can find a visible icon on the status bar indicating that the music is still playing
2. If the user finds the play icon on the status bar and decides to take some action, he/she can swipe the notifications icon or swipe down from the top of the screen. This action opens up the utility tray  with details of the current song at the bottom of the utility tray
3. The utility tray should display the song playing, the album art and the music icon 
4. The user by selecting the song in the utility tray can go to the music app to take some action
Blocks: koi-media
Whiteboard: [ucid:Media 12]
Whiteboard: [ucid:Media 12] → [ucid:Media 12] feature=story c=music
Assignee: nobody → dkuo
If I understand this bug correctly, it a simple one:
* Use mozChromeEvent: audio-channel-changed event
* When evt.detail.channel is changed into 'content': show the icon.
* When evt.detail.channel is changed into all other: hide the icon.
Whiteboard: [ucid:Media 12] feature=story c=music → [UCID:Media12, FT:Media, KOI:P1] feature=story c=music
Hi Eric, currently we don't a playing icon on the status bar, can you please provide the new icon for this user story? thanks.
Flags: needinfo?(epang)
Attached file Statusbar Icons.zip
Hi Dominic,
I've added the play icon to the status bar icons at @1x and @2x (it's the last icon).  The only thing I'm worried about is that I'm not sure if I've worked off the latest version.  Is there a way we can pull the latest so I know I've added the play icon to the latest version?  Let me know if you find out it's not the latest - if you point me to the latest I can update it :)

Thanks!
Flags: needinfo?(epang)
Eric, thanks for the new images, and I think we also need the icons at @1.5x.

You can just pull the latest gaia master branch to see the latest images, and you probably need do the daily update because the master branch is always changing. So I will suggest you just look them on github which should be easy and fast to check the latest version.

All the latest images should be in the master(If not, that should be some bugs...):
https://github.com/mozilla-b2g/gaia/tree/master

And the image we are looking for this issue is:
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/style/statusbar/images/icons.png
koi+ per https://wiki.mozilla.org/B2G/Roadmap
blocking-b2g: --- → koi+
Attached image icons@1.5x.png (obsolete) —
Hi Dominic, I've attached the image @1.5x. Let me know if anything else is needed! Thanks :)
Blocks: 900310
Hi Eric, while I was replacing the current icons@1.5x.png to attachment 784975 [details], I found the battery icon in the second line, the first one looks slightly different, for 1.5x the border is red, but for 1x and 2x are white, not sure which one is correct and we will need these three sync, thanks.
Flags: needinfo?(epang)
Attached image icons@1.5x.png.png (obsolete) —
Hi Dominic, I've updated the icon so it has a white outline and matches 1x and 2x.  Sorry I didn't catch that myself!  Let me know if there's anything else that's needed. Thanks!
Attachment #784975 - Attachment is obsolete: true
Flags: needinfo?(epang)
Attached image icons@1.5x.png
Attached the wrong files.  Please use this one, thanks!
Attachment #792743 - Attachment is obsolete: true
Alive,

This patch basically implemented what you suggested in comment 1, with the new 1x, 1.5x and 2x icons images. Besides adding a test case on this new feature, I also wrote four cases that covers the mozChromeEvent changes, which were not there and looks all related to the media features, so I called it "media information" test suite, can you please review it? thanks.
Attachment #795437 - Flags: review?(alive)
Comment on attachment 795437 [details]
Show play icon on the status bar when music is playing

Thanks for add tests!
Attachment #795437 - Flags: review?(alive) → review+
Thanks Alive!

This bug will only cover the first Acceptance Criteria in comment 0:

1. The user exits the music application and keeps the screen in unlocked state. He/she can find a visible icon on the status bar indicating that the music is still playing

The others are in bug 902974 and bug 902981.

Landed on master: e0588920dc1cf4d3cfeefc65c89d44cf3ff4f12c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Component: Gaia::Music → Gaia::System
Attaching the link of demo video for UX/Prod to sign-off.
Sri/Rob,

Would you please review the demo of this user story in attachment 796431 [details]? thanks.
Flags: needinfo?(skasetti)
Flags: needinfo?(rmacdonald)
Dominic, 

I reviewed the demo and it looks good.
Flags: needinfo?(skasetti)
Hi Sri,

Does this cover FM radio playing as well or should we consider extending it to?
As requested by partner in bug 908584.
Flags: needinfo?(skasetti)
I don't think this covers the FM Radio app. Let's check with Dominic to be sure
Flags: needinfo?(skasetti) → needinfo?(dkuo)
Flags: in-moztrap+
(In reply to Sri Kasetti from comment #19)
> I don't think this covers the FM Radio app. Let's check with Dominic to be
> sure

AFAIK this does. If it doesn't, it's a bug falling under audio channel service.
I took a quick test and found FM radio use the same audio channel as well(content channel), so the play icon also shows up when FM radio is playing! I am setting the dependency and closing bug 908584.
Flags: needinfo?(dkuo)
Blocks: 908584
Duplicate of this bug: 908584
Duplicate of this bug: 900310
Duplicate of this bug: 796303
Duplicate of this bug: 834750
Hi Dominic... 

Thanks for putting the video together. It looks good. Can you do a screen shot of what shows in the activity tray? One of the items we had for MVP from the UX perspective was that we show the album art, song title and artist in the utility tray and then link that to now playing. Assuming we can't get playback controls yet, we'd hope to see that instead.

The idea is that, if we're providing the play icon, users will need to know what it's for and be able to access it. 

Which brings up the topic of FM Radio... If we're showing a play icon in this case, then we'd apply the same logic and would like a link to the FM Radio app from within the utility tray during playback. Something like...

------------------------------
[icon]  FM Radio           >
        94.2        
------------------------------

Just try to visualize. :)

I know this wasn't anticipated but let's discuss whether this is feasible.

Rob
Flags: needinfo?(rmacdonald)
No problem, and the information for FM in the activity tray is a good topic, let's file a new bug and discuss in it!
See Also: → 929416
You need to log in before you can comment on or make changes to this bug.