If I search for London the only thing I get is Dees' profile

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sole, Unassigned)

Tracking

Details

Attachments

(1 attachment)

That's it really. I'm not logged in, that's not the expected outcome, I guess :-)
I _believe_ this is the expected outcome:

1) When there's only one result, it is shown instead of a list page with one result
2) As a logged-out user, you will only see results that include at least one public field (and one must be the username or fullname)
3) I _believe_ right now there is only one person in London with public fields

Since you might normally show up in these results, can you test my theory by making one of your fields public?

Thanks!
Flags: needinfo?(sole)
I can confirm that multiple results for "London" are returned for vouched, logged in users. https://mozillians.org/en-US/search/?q=London

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
Created attachment 772194 [details]
qa - wfm on prod

Bumping this to worksforme - I updated my profile to include "London" as my hometown city and set that field to public.

My profile is now returned in the public results

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Sole, thanks for reporting this issue! While it's not a bug with the site, we can improve things by having more Mozillians in London mark their profiles as public (specifically, their name and city).

You can quickly do this by editing your profile https://mozillians.org/user/edit/ - feel free to share this with other Mozillians in London and asking them to do the same :)
(Reporter)

Comment 5

5 years ago
Yep, I changed my fields to public and now a very short list of mozillians is shown - dees and me :-D

I am glad we sorted this out, but it was an strange decision nevertheless :)
Flags: needinfo?(sole)
(In reply to Soledad Penades [:sole] [:spenades] from comment #5)
> Yep, I changed my fields to public and now a very short list of mozillians
> is shown - dees and me :-D

Awesome - bumping to verified per comment 5.

> I am glad we sorted this out, but it was an strange decision nevertheless :)

I'll file a bug to re-open the discussion on what the default behavior should be if only one result is returned and cc you on it so you can track the conversation
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.